Json lang file not working

Hi, I’m trying to add second language (the default is English, and I’m trying to add Norwegian). I have finished this manual Tutorial: A complete guide to translation & multi-language content in Ghost and i have dynamic routing, the posts work fine. For Norwegian lang I have in html attribute lang <html lang="no">
But json file no.json doesn’t work, in locales folder I have 2 files en.json and no.json. In files hbs I use this syntax {{t 'blog_title'}}, and in settings my default lang is English.
I don’t know what I’m doing wrong.

The translation helper supports have one language active at a time, which is determined by what you have set in your Settings in Ghost Admin. If you change the language there to Norwegian, then do you see the language change your were expecting?

If you want to do a multi-language site, then you’ll need to just follow the instructions in the earlier part of the tutorial (collections, {{#has}} helper, etc.).

Thanks for answer. I thougt, that it work in this way:

url: localhost.local
ghost use default lang for example en.json

url: localhost.local/no/
ghost use no.json

Is it posisble?

Unfortunately, that’s not possible.

You’ll need to use a custom collection to achieve that. For post.hbs and other templates, you’ll need to use the {{#has}} helper.

Thank you for the answer.