Login Failed: Please update your credentials

Logging in from MacOS native client. I get the error above. Confirmed that it is not that the password is invalid by logging in from the web portal. Changed password as well and still does not allow login from MacOS client.

Ghost on MacOS Version 1.7.0

Still having problems with this? It may be caching your credentials on the machine, did you restart the app before logging in again?

Yes, I did, and for a while I was getting a 502 gateway. Which has now stopped and its back to being live. This is hosted here with Ghost.

Above comment was re: out on the net.

Re: login, still hopeless. I don’t want to switch to self-host, but I’m becoming a tad more interested the more this headache endures. I am trying all of the suggestions. But I’m gonna need more, because I ran with what you suggest and still no luck.

Final reply for now.

The issue is now “too many login attempts” on the web interface - perhaps this is all that the issue is now at this juncture. If ghost team can reset that, I will re-attempt.

But for the record, it was not the issue last night, as I was able to login thru the web interface, which i did to be certain that I was using the correct password.

It sounds like you’re on Ghost (Pro); have you emailed Ghost Support?

Hey @ercfre ! If you’re a Ghost(Pro) customer, please send an email to support@ghost.org and we’ll help you from there!

As far as I can tell this is a bug in the Native App, and I’m also using version 1.7.0 on Mac OS. It happened to me a couple of weeks ago when logging in for the first time to a new instance. In the first login attempt on instance #1I got the exact same message as you. I swear I had the password correct and so tried again, and it logged me in.

A minute later I tried logging into instance #2 and had the same result: error message. I thought something was fishy cause it was the exact same password I was using on instance #1 (these are spec installs, not the real deal). I re-typed in the password and it let me in.

Today I signed into yet another spec instance (#3), pasted in the password, got the error message, pasted in literally the exact same password from the clipboard, hit “try again” or “login” (or whatever the button says) and it worked fine.

So as far as I can tell there’s a bug whereby the first login attempt doesn’t work, but the second does.

Edit: If it makes a difference, instances #1 and #2 were on Ghost version 2.23.3, instance #3 which I just logged into a moment ago via the Native App is on version 2.25.3.

I do not experience this.

I am glad to hear though that this is not an isolated issue, as I am sure support might try to suggest.

Hi all,

I’ve just done some debugging on the native macOS app and there does seem to be issues when logging in and adding a blog.

For now I’ve found that when you try to add a blog it’ll fail, but the icon will appear in the top left of the screen. If you click that icon it’ll take you to a different login view. Ensure you’re using the single user account you have for the site in question and log into this view. Hopefully it’ll get you into your site.

Sorry for the problems people are having, we’ll hopefully address this issue soon

2 Likes