Lyra theme signin/signup

Good evening,

I adjust my post.

I had badly imported the template.
I reinstalled Ghost and re-downloaded the Lyra template from github.
I imported the new router.yaml file, but when I click on signin o signup I get the error 400.

I take the opportunity to notify a wrong link in the documentation.
At the end of this page, the “theme development” link redirect to a 404 page.

Thank you.

Thanks! Just fixed that broken link and it will be live in just a moment :slight_smile:

Once you’ve imported routes.yaml you’ll need to restart Ghost for it to take effect. Let us know how you get on!

I tried both to restart and stop it completely and start it.
I encounter error 400.

# 400

Missing template members/signin.hbs for route "/signin/".

[Go to the front page →](http://localhost:2368/)

As you can see I’m testing locally.

In the root, I see the “members” folder and the account/signin/signup.hbs file correctly

I would also like to notify this warning message when I import Lyra just downloaded from github:

## Warnings

* [
####  Replace  `{{#each}}`  with  `{{#foreach}}`
](http://localhost:2368/ghost/)The  `{{#foreach}}`  helper is context-aware and should always be used instead of Handlebars  `{{#each}}`  when working with Ghost themes.
See the description of  `{{#foreach}}`  helper [here](

###### Affected files:

  * `index.hbs` : Please remove or replace undefined from this template

I am also facing same error.
I have moved all the template files ( account.hbs, signin.hbs and singup.hbs ) from the members directory to theme root.
In each file changed {{!< ../default}} to {{!< default}} for the correct path of default.hbs template/

Also changed the routes in routes.yaml as following

  /signup/: signup
  /signin/: signin
  /account/: account

It’s working. But from the sub-directory members or any other sub-directory no templates are accessible.
Same 400 error with same missing template message.

NOTE: I am testing on local machine, development mode. OS- WIndows 10

Theme development link ( is broken again.

This page has moved to:

1 Like

Same thing here, the members directory is being ignored and so i’m getting 400 Template missing errors.

Testing on a local copy installed via Ghost-Cli on Windows 10

seems to be a local windows problem, on ubuntu I don’t see the problem.

Definitely a windows issue.

Found a workaround, changing the route paths to use back slashes instead of the forward slashes works

like this

/signup/: members\signup
/signin/: members\signin
/account/: members\account

1 Like

I confirm, it works, thanks!