Error 400: Missing template members/signin.hbs for route "/signin/"

Hi there,

I’m having trouble with a theme I am developing. As I find this problem on this forum yet, I didn’t manage to fix it. And I don’t understand why it don’t runs.

First of all:

I can’t post you a link because I will upload the new theme on a blog who is running well yet. If the theme don’t run correctly, I can’t let it in place.
I use the last version of Ghost (local and online).
I work on MacOs (last version) for Ghost local
Last versions of Node recommended for the installation of Ghost.
Online, the site is hosted by Ghost (ghost pro).

Here is my problem:

The sign-up/sign-in/account pages are not showing when I upload the theme online as it returned a 400 error Missing template members/signin.hbs for route “/signin/”.

What is strange is that locally, there is no problem at all. the sign-in, sign-up pages are working perfectly.

Once I put it online it don’t works.

I tried to:

  • Modify the route.yaml file, as I found solutions on the forum: it don’t works,
  • Move files on a another folder, and specify it on the route.yaml: it don’t works,
  • Alternatively, what the error show me online is not corresponding of what I have in my folders, as the templates are not in the folders members/sign-in, but in the root of the theme, as a custom-sign-in.hbs file, so I tried to move up the files, it don’t works either.

What I don’t understand, is why locally, it runs, and online, not?

Here is attached screenshots of the problem.

And what is strange too, is that I have a “tags page” (based on a template), in the root of the theme, as a custom-tags.hbs, this page is running perfectly online and locally. All the other template pages I’ve created as custom pages are running locally and online, except for sign up, sign in and probably account.

If someone has a solution, it would be really great!! Thanks in advance!!

To ask the obvious question first, are the template files definitely getting zipped up when your theme is shipped to your live site?

Hi Hannah,

Thanks for you quick answer :slight_smile:

Yes the files are always zipped (locally / online).

To be clear, because I read again the post, all the theme is running well online, except when I click on sign-up, sign-in button, it shows the current error.

An error that I don’t have locally

Hey Matt-B, I had a similar problem with the theme I used. Luckily the Theme creator also shipped theme documentation with the theme, that had the solution to the problem. In my case, it was simply the case of:

  • Reset the routes.yml file and
  • create a page pointing at the URL /signin/ and
  • create a page pointing at the URL /signup/

In your case, you can try the above or reach out to the theme creator for help.

Hi @EchonCique

Thanks for you help!

I’ve tried the solution you provide, but the error is still here.

Even when I activate the casper default theme, when I hit url of the sign-in, it show me the same error

I’ll try another solution by modifying my theme for the login

Hi @Hannah and @EchonCique

Finally, I opted for the ol’good solution, as creating a page-sign-in.hbs with my custom code in it. And then create the page in the ghost administration, with the correct link to it.

And it runs perfectly.

It seems that the thing with custom pages and templates pages don’t run well with the sign in / sign-up? As I see, this error occurs too with the casper default theme,

So my solution to it was to create a proper page, and not using templates pages for the sign-up and sign-in,

Anyway, thanks for your help! :slight_smile:

1 Like