Mailgun / Email Service Currently Unavailable

Specs / Info:
Ubuntu 20.04 on VPS
Ghost 4.27.2 (also persisted in 4.25.x) :Port 2368
NGINX 1.18.0
UFW disabled (for troubleshooting)

I get the “Email failed to send when publishing this post. Please verify your email settings if the error persists. / Error: Email service is currently unavailable - please try again” error when trying to send a post to 75 paying subscribers.

  • Transactional (SMTP) emails work fine for password resets, etc.
  • My Mailgun account is NOT on probation. It was at first, but Mailgun has since lifted it

JSON config:
“mail”: {
“transport”: “SMTP”,
“options”: {
“service”: “Mailgun”,
“host”: “”,
“auth”: {
“user”: “postmaster@mail.[DOMAIN].com”,
“pass”: “[PASS]”

Does anyone see any problems I’m missing here? Mailgun tells me they’ve lifted the rate limit on my account to allow for more than 10 emails being sent at once, but I still can’t mail out to my subscribers en masse. I can send fewer than 10 emails at once, however. It almost feels like I’m still being limited by Mailgun but I’m new to Ghost so maybe I’m missing something.

My Mailgun domain is green and verified in terms of DNS settings

The failure to send does not create an event in my production.error.log file.

Any ideas?

We have faced a similar issue for our visioun blog. In our case, API IP security was turned on & I forgot to whitelist the server IP at Mailgun.

You can check it at Setting > API Keys

Under IP whitelist if you see any IP there that means your API IP security is turned on. In that case, whitelist your server IP & It will work Fine.

1 Like

So, interestingly enough – Mailgun had to re-lift the limit they’d imposed. This is now solved. The tech who had emailed me and said that the account restriction was lifted apparently did not correctly lift the probation and another tech had to re-work it.

1 Like

Glad to hear, that your problem has been solved.