Make site private, unable to login, page keeps redirecting on login

Issue Summary

I am setting up a new ghost self-hosted site, I tried to make the site private. When I accessed the site I was able to see the dialog This site is private and the password field.
After entering the password and clicking on access site, the page redirects back to the password page.

Below is the browser network request flow:

Steps to Reproduce

  1. Make the site private
  2. Login to the private site

Setup information

Ghost Version

Node.js Version

How did you install Ghost?
Ghost packaged by Bitnami on AWS Lightsail instance.
Version: Bitnami package version: 5.67.0-2-r02 on Debian 11

Provide details of your host & operating system
AWS Lightsail running Debian 11

Database type

Browser & OS version
Google Chrome Version 117.0.5938.150

Relevant log / error output

Can you try with a different browser, or not in incognito mode, or unblock cookies? The login information requires cookie storage, so if it can’t tell you’re logged in, it’d redirect…

1 Like

Thanks for responding.

I tried in Firefox and yes I was able to login to the private site.
I also tried in regular google chrome(not incognito) and it didnt work there too.

I also found the same issue raised by someone few months ago in this forum earlier and they have posted a bug request in Github.

I am not blocked since its working at least in firefox

I’m glad you’re not blocked.

I used private mode just yesterday with Chrome (windows 10, recently updated). So this is not an all-Chrome problem. But it could be an extension, or one specific version or OS, or an especially strict security setting.

I’ll check my Chrome version when I’m at my desk. That’s a fairly new version, so perhaps you’re the first to hit the problem? If not, if you want to chase this further, you might try turning extensions off temporarily and setting Chrome back to defaults on any security/privacy settings.

I do have very few extensions on my chrome, but I also tried this in Opera, Brave, Microsoft Edge where I have no extensions or any other third party code which can affect the page.

It does not work in any of the above chrome based browsers, it does not seem to be an extension issue but compatibility issue with the chrome engine.

You may also refer to this post with the same issue.

one more update:
@Joe_Blocher has already fixed the issue and raised a PR at

but its not been merged yet.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.