Members Email Confirmation Not Working

If you’re looking for help, please provide information about your environment. If you delete this template and don’t provide any information, your topic will be closed.

If you aren’t running the latest version of Ghost, the first thing we will ask you to do is update to the latest version of Ghost.

  • What’s your URL? This is the easiest way for others to help you
    https:// archernewton.com
  • What version of Ghost are you using? If it’s not the latest, please update Ghost first before opening your topic
    3.38.3
  • How was Ghost installed and configured?
    We are using https://hub.docker.com/_/ghost as the actual docker container
  • What Node version, database, OS & browser are you using?
    This is determined by the exact container itself
    OS: Debian 10 (buster)
    NodeJS: v12.20.0
    Database: N/A
    I’m using google chrome on macOS Big Sur
  • What errors or information do you see in the console?
    Errors related to the mail issue currently: Failed to send email. Reason: Can't send mail - all recipients were rejected.
  • What steps could someone else take to reproduce the issue you’re having?
    To replicate the issue you can use our direct startup for the container as well as our configuration file.
    docker run -d --name some-ghost -e url=https://archernewton.com -v
    /var/www/archernewton.com/ghost/content:/var/lib/ghost/content --env-file
    /var/www/archernewton.com/env.list -p 3001:2368 --restart=always ghost:latest m -v
    /var/www/archernewton.com/ghost/content:/var/lib/ghost/content --env-file

env.list is: SPACE ADDED TO BREAK LINKS SINCE I CAN’T POST MORE THAN 3 LINKS AS A NEW MEMBER
mail__transport=“SMTP”
mail__from=“archer@ archernewton. com”
mail__options__host=“mail. vengyn. net”
mail__options__port=“465”
mail__options__secureConnection=“true”
mail__options__auth__user=“archer@ archernewton. com”
mail__options__auth__pass=“REMOVED FOR SECURITY”
You can also just go onto our website and then click subscribe in the top right and it doesn’t work as it says the that is not a valid email address

What are your mail settings in production.config.json?

So the problem with seeing/modifying the production config is that once the container is updated, changed, or modified, that file is overwritten with the default configuration. Any additional configuration, for example like the mail options we are trying to do has to specified within the env.list file otherwise it will be overwritten. Now unless someone has a way of stopping this from occurring and having it export to the same data folder as the installation then I can see how this would be the case, at this moment though that isn’t within the realm of possibility for our dockerized setup.

Ok. Just for the sake of testing, can you use Mailgun?

Unfortunately as the current mail setup is forwarded to a custom mail server (mail.vengyn.net) which works 100%, we are unable to migrate from it. We know the failure has to do with the configuration, now while researching and finding several articles on this subject, only one provided what we use currently. We are just unsure as to what could be the root cause of our issue, due to the logs being very vague.

Weird one, but try using 587 and removing the line secureConnection=true

Tried this and it’s still the same result

Does anyone any advice that we might be able to try?

Still struggling with this issue?

Bump

Bump

Any ideas?

Is there more information that I need to provide?