Metatags are not being loaded on /pages URL

Hi everyone,

I’ve noticed that the defined metatags on ghost admin are not being loaded on posts pages.
Do you know how can I solve this issue or his something that needs to be done from ghost team?

I’m using the last version of ghost

Best regards

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you:

  • What’s your URL?
  • What version of Ghost are you using? The version number
  • What configuration?
  • What browser?
  • What errors or information do you see in the console?
  • What steps could someone else take to reproduce the issue you’re having?

Thanks! :blush:

Hi @DavidDarnes,

Here is some additional information:

  • What’s your URL?
    https://www.imaginarycloud.com/blog/
  • What version of Ghost are you using? Version: 2.21.1
  • What browser? Google
  • What errors or information do you see in the console? Any error related with this issue
  • What steps could someone else take to reproduce the issue you’re having?
    Go to, https://www.imaginarycloud.com/blog/, and inspect with chrome dev tools. Then go to head HTML element and you can see that meta descriptions are being loaded (eg: meta description).
    If you go to https://www.imaginarycloud.com/blog/page/2/ the metatags are no longer available. This metatags are being set up in ghost admin.

Best regards,
Bruno

This is quite an old version of Ghost. You should consider upgrading to remedy any bugs that may have been fixed since your version was released :blush:

This is on 3.24 as well. The meta description doesn’t get added. I’ll post a separate message about this.