Moderating ghost comments

Hey ghosts,

I didn’t find a possibility to moderate or comment ghost comments with my owner account. Then I stumbled over an issue, that I can’t even read “member only” posts as an owner. Until now I was working around this issue by subscribing to my own ghost sites - because I can only see public posts/pages as an owner, if I don’t do this - which is strange. I would expect to see everything as a site owner when I press on “View site” on my Admin Dashboard.

How are you supposed to:

  1. View your complete page as an owner, including “member only” sections?
  2. Therefor be able to moderate comments in the new ghost comments?

I didn’t find anything about these 2 points in the documentation or the forum.

Would be glad if someone could open my eyes :smiley:

1 Like

Hey! You’ll want to add yourself as a Member, and log into the frontend with that account.

But how am I able to moderate comments then? How does the site know, that I’m the owner, and not just a member?

1 Like

When you’re logged in as a Member AND you’re logged into the Admin, the site will attempt to read your Admin cookie, and this will enable moderation on the comments, we recommend using Google Chrome for this, as other browsers can have issues reading the cookie


Oh, maybe that’s the problem. I’m using Firefox.

Please update your Ghost CLI and update Ghost version to 5.9.4. There was a issue in 5.9.3 and it was fixed in 5.9.4. Thanks to @egg for fixing that issue.

More moderation features and options will be available. We can suggest them new features and the options that we need in comments.

1 Like

@c4bfevr there’s documentation for the moderation feature available here, still I can’t get the feature to work in either Chrome or Firefox.

@egg are there any specific requirements for adding yourself as a member to be able to moderate comments? I’ve tried with the same email address as with my owner account, and I’ve also tried with other email addresses but I still can’t access the feature. I’ve noted a more thorough description of my issue here. I should probably add that I’m testing the feature in a local installation, maybe moderation doesn’t work in that environment?

@thimiraonline great to hear that more moderation features and options will be available, hopefully that will address the rather cumbersome process with double sign in as admin and member just to be able to moderate.

1 Like

What is your Ghost version?

@thimiraonline My Ghost version is 5.10.1.

@provesay there’s no requirement to be logged in as any particular member, just that you are logged in as a member on the front-end and as an Administrator/Owner account on the back-end.

If it’s not working for you at all, please check your web browser’s console for any errors - it could be that the admin cookie is being blocked in the cross-domain request or even the admin-auth url being blocked completely.

5.10.1 means the latest version. There is no any issue for me with the comments.

Lets do this. First of all, you have to be a member from the front end sam as others. (Please use your ghost administrator/owner email to login with) Then you can moderate comments.

If it is not working for you, you should follow below steps.

Update your ghost CLI
Run ghost buster (This will clear your yarn cache)
Run ghost restart
Clear browser cookies of your website
Login to your Ghost admin account
Login to your Ghost frontend member account

This should work for you.

1 Like

Also @Kevin

Just to list the exact specifications here:

Environment: Local installation
Ghost-CLI version: 1.22.0
Ghost version: 5.10.1 (at c:\Ghost)
Node.js version: 16.16.0
NPM version: 8.18.0
OS: Windows 10 Pro 21H2 (19044.1889)
Browser: Chrome 104.0.5112.102

I’m using the same email address for the owner account and the member account. I’ve also tried different email addresses but it didn’t make any difference.

I took a look in the console before and after performing the steps that @thimiraonline listed.

When I logged in to the dashboard this was found in the console, but that error didn’t show up on the blog post with the comments.

:2368/ghost/api/admin/users/me/?include=roles:1 Failed to load resource: the server responded with a status of 403 (Forbidden)

Despite the error the dashboard worked just fine.

After performing the steps listed by @thimiraonline the error was gone when logging in to the dashboard, but the comment moderation issue still remains.

As you recommend Chrome for this I’ve performed the troubleshooting in that browser, but I’ve also tried it in Firefox as that is my main browser. Firefox is more verbose in the console output but :2368/ghost/api/admin/users/me/?include=roles:1 is nowhere to be found there. But both browser do log this error:

localhost/:146 GET http://localhost:2368/public/comment-counts.min.js?v=c66edb3d1c net::ERR_ABORTED 404 (Not Found)

I’m doing a search for that file in the entire Ghost folder but nothing’s shown up yet so just based on the name I’m guessing it’s a script for counting the amount of comments and it shouldn’t affect the moderation?

Should comment moderation work even in a local development installation, or might there be some issues with this feature in that environment? Everything else is working just fine, I can comment, reply, like, delete and report comments, it’s just the moderation that isn’t working.

Just to be sure that the issue isn’t in my local installation I made another local install in another folder and the issue is the same there, and comment-counts.min.js is missing there as well.

EDIT: The admin cookie is present in both Chrome and Firefox.

It sounds like there are issues with the script generation seeing as the comment-counts script hasn’t been built, there’s another admin-auth script that is built in the same way and is required for comments moderation to work.

Windows isn’t a tested platform so it’s possible there are problems there. If you have related errors in your ghost logs then sharing those could help someone fix it.

Holy mother, you are on the localhost. I thought you are on prodution site. :no_mouth:

Ah, then it might be related to Editor vs Reality (Self-Hosted) which leads to a documented issue in GitHub: Cannot generate assets (cards, admin-auth, etc) on local windows install · Issue #14278 · TryGhost/Ghost · GitHub.

I’m guessing the logs for this are the ones found in C:\Ghost\content\logs and primarily it’s the ...error.log that contains the information needed in this case? Since it’s a local installation I figure that the logs don’t contain any sensitive information, except for maybe an email address or something like that somewhere, so I should be able to upload the logs somewhere without having to fine-comb them first?

Should I report this as a bug in GitHub, just like the one I linked to above?

I made another local test installation on Ubuntu 20.04 using WSL and comment moderation works fine there, both in Chrome and Firefox. I’ve added this as a bug report in GitHub and we’ll see if someone can fix it somewhere down the line.

I have the same issue, and I’m on the hosted instance of Ghost. I’ve logged in both as a subscriber as well as the admin panel but I can’t moderate comments. I’ve checked and the admin cookie is set.

Ok it looks like it might have something to do with my browser that I’m using (which is Brave). I tried it in Chrome and it’s working fine.

@seanwrightsec @provesay what is your Ghost version?

Comment moderation is working fine without issue on my website. I cannot imagine what’s wrong with your websites guys.

Here you can see how it is working on my website.