New post are not sent to all subscribers

I have a situation where new posts are not sent to all subscribers (74), but only to a small subset (6).
The post access is set to public, and, even when changing the post access level to members, the destination count stays the same (6).

Am I missing something?

Version: [5.71.0]

Environment: production

Hey @leforum! Welcome to Ghost!

I’m assuming you’re using the built-in functionality, where you hit ‘publish’ on the post and then choose ‘email only’ or ‘email and publish’ ?

When you click to a post, you can choose who it goes to. Perhaps you have ‘free’ or ‘paid’ checked, when you meant to have both checked? Also check on that same page that you don’t have the post set to go to only members with a specific label. If you can screenshot that screen (where you choose who gets the email), I might be able to help you troubleshoot it.

The “post access” affects who receives full content (instead of any public preview followed by a ‘call to action’ nag to subscribe), but shouldn’t affect whether the email goes out or not.

Yes, I’m using the built-in functionality, where I choose ‘email and publish’

And, as you can see I get only 6 recipients, where my subscribers are 73.

Finally, ‘post access’ is set to Public.

Thanks for your help.

To complement, my subscribers are 73


It’s possible your members aren’t signed up for the newsletter?

1 Like

Uh! How do I check that info? This site it’s been live for over a year, is it possible that during the rollout of the ‘newsletter’ feature existing members do not get signed up by default?

1 Like

Very possible!

To make sure new members get signed up for the newsletter, go to /ghost > settings (gear icon) > newsletter. Hover over the newsletter and an edit button will appear:

(where the yellow highlight is). Click it, then scroll down to find the slider than makes subscribing the default.

Be sure to hit ‘save’ afterwards.

Did your members sign up directly on Ghost, or did they sign up somewhere else and then you imported them? If you are importing members by uploading a CSV (which you can do in the picture below, accessed from /ghost > members), you’d want to indicate whether to subscribe them to the newsletter or not.

To sign them up (assuming that they’re not signed up due to an error, NOT because they deliberately unsubscribed), you could ‘export’ your members, change the “subscribed to emails” field, then import it again.

Hope that helps!

1 Like

Hi Cathy.
‘Subscribe new members on signup’, checked. Usually, new members have no issues receiving new posts, but rather existing members.

I exported all members as you suggested, and here’s where the pot thickens, out of 73 members, only 2 have ‘subscribed_to_emails’ set to FALSE.

Any ideas?

Huh, ok. So if you look at a few of these members individually (in the admin portal), do you see them subscribed to this specific newsletter? I’m wondering if they’re subscribed to emails, but NOT to this specific newsletter? Don’t look at all 73, but definitely take a look at a couple?


Yes, those 73 are subscribed to the newsletter.

That’s really weird, @leforum! I’m sorry I don’t have a great idea or fix for you on this one. It’s really weird that the publication page is only showing six members, when you clearly have more!

If you’re self hosting, I’d suggest stopping and restarting Ghost. I don’t think that’s going to fix it, but it might. There’s some synchronization between Ghost and Mailgun that brings back analytics and information about emails bouncing… and it can definitely stop sync-ing occasionally. No promises, but easy to try.

You could also try unsubscribing and resubscribing a few users - if the count displayed when you push publish changes, that might be informative?

It is informative. Is there something at the database level that I need to check?

If you slide the slider on and off for the user (your last image), does the number of users showing up in the email screen change?

I think I solved this. I updated the table ‘members’, field: ‘email_disabled’, all of the members had ‘1’ in this field but 6 of them. The solution consists in setting this field to zero. After a quick restart, most members are ready to get their posts.

Thank you all for your support.

1 Like