NO ONE can upload featured photo due to "Request was rejected because user is not permitted to perform this operation"

AGAIN! Nobody on my team is able to add a feature photo to this blog draft. We have all tried multiple times, logged in and out, used the official owner account, used incognito, refreshed multiple times, created new drafts. Literally everything.

Ghost really needs to fix this simple UI bug that’s impeding my work flow and slowing things down.

Please help!

Are you self-hosting? If yes, how? What does your setup look like?
Is there anything in the browser console or your Ghost logs?

If you’re not self-hosting, where are you hosting your Ghost site? Have you reached out to their support?

1 Like

I am self-hosting. I reached out to support and they couldn’t help me since the site is self-hosted. This is what the dashboard looks like

The page is IoTeX News and Announcements - Stay Up to Date on IoTeX

Can you provide this information, so we can help you better?

Edit: just did a quick search in the forum for the error message you see and found this:

Could very well be an issue with your setup.

Try the task with the Network tab of Developer tools open. What is the HTTP response to the request? What do your Nginx access and error logs look like for the event?

If the details indicate that is really Nginx and not the Ghost backend blocking the upload, then you might need to increase the max size allowed for Nginx uploads.

Review your Nginx config for the site in /etc/nginx/sites-enabled/ and confirm that it has client_max_body_size set to similar values to this:

    client_max_body_size 50m;
    # Trust admins to upload large files.
    # Nginx requires repeating directives here
    location /ghost/api/admin/media/upload/ {
        client_max_body_size 0;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto $scheme;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header Host $http_host;
        proxy_pass your_value_here;

Did you check the folder permissions? Run ghost doctor at the ghost installation folder with ghost user you created in your VPS. It will tell you what’s wrong. If you’d like have an expert hand regarding this, please let me know. I’ll help you.

Ghost doesn’t respond with a 403 / permission error response for the image upload endpoint. If it was unable to write a file due to permissions it would return a 500.

My money is on something in your server or network setup that is blocking the request. Do you use Cloudflare? A search of the forum shows others had problems with Cloudflare blocking image uploads:

1 Like