Not compatible with your version of node/npm: ghost-cli

Help me, please!
I have updated Nodejs version to 14.14.0 and couldn`t start Ghost. I had a message:

Message: The version of Node.js you are using is not supported.
Debug Information:
OS: Ubuntu, v20.04.1 LTS
Node Version: v14.14.0
Ghost Version: 3.15.3
Ghost-CLI Version: 1.13.1
Environment: development
Command: ‘ghost doctor’

I have been trying to update my CLI version (sudo npm install -g ghost-cli@latest), but I have this:

npm WARN notsup Unsupported engine for ghost-cli@1.15.2: wanted: {“node”:"^10.13.0 || ^12.10.0 || ^14.15.0"} (current: {“node”:“14.14.0”,“npm”:“6.14.8”})
npm WARN notsup Not compatible with your version of node/npm: ghost-cli@1.15.2
+ghost-cli@1.15.2
added 419 packages from 208 contributors in 30.147s

How can I update my Ghost CLI version, Ghost Version for using with my Node version?
Thank you)

Hey @Svetlana_Tsupryk! :wave: Our minimum supported version of Node 14 is 14.15.0, as this was the version released when it went into LTS. You’ll need to update your Node version and then it should work :slightly_smiling_face:

Thank you! :blush:

@daniellockyer
I am very grateful for your help)
I have updated Nodejs to 14.15.1. Now I dont have warning, but my version of CLI haven`t changed:

Debug Information:
OS: Ubuntu, v20.04.1 LTS
Node Version: v14.15.1
Ghost Version: 3.15.3
Ghost-CLI Version: 1.13.1
Environment: development
Command: ‘ghost update --force’

Maybe you know why? I still have recommendations to update Ghost-CLI.

I have found that I have two versions of CLI

Oh - very odd! I’m not sure why you have two versions. The one at /usr/bin/ghost must be first in your $PATH, so that’s why you’re seeing the message.

I’d possibly suggest deleting /usr/bin/ghost, so you can just type ghost which will use /usr/local/bin/ghost. But 1.15.2 is definitely the correct version at the time of writing :slightly_smiling_face:

Thank you)
I have done
Ghost CLI Update issue and Ghost CLI Update issue. But now I have new error(

mv /usr/local/bin/ghost /usr/local/bin/ghost2 && ln -s /usr/bin/ghost /usr/local/bin/ghost

This seems to be because you’ve just symlinked the /usr/bin/ghost binary to /usr/local/bin/ghost, but during the installation it is trying to symlink from ../lib/node_modules/ghost-cli/bin/ghost to /usr/local/bin/ghost and detects the issue.

I would try:

  1. rm /usr/bin/ghost
  2. sudo npm install -g ghost-cli@latest

Alternatively you can:

  1. rm /usr/bin/ghost
  2. mv /usr/local/bin/ghost2 /usr/local/bin/ghost

:cry:

:sweat_smile: Ok so here you can try sudo npm install -g ghost-cli@latest --force.

I wanted to check, have you deleted /usr/bin/ghost yet? This is the old version of Ghost-CLI we hopefully shouldn’t need now.

1 Like

Nope

Can you try with --force as per my comment? :slightly_smiling_face:

Sorry I meant this one.

ie. sudo npm install -g ghost-cli@latest --force

Ok let’s try:

  1. rm /usr/local/bin/ghost
  2. sudo npm install -g ghost-cli@latest --force

@daniellockyer Thank you very much for your help! :clap:
It was very unexpected that it would be personally from you :star_struck:, this is big honor for me)
Thank for your time and kindness! best wishes :smiley:

1 Like