The version of Node.js you are using is not supported


#1

Hey guys. Trying to upgrade my little ghost here, and it’s telling me that I’m ahead on my node version:

One or more errors occurred.

1) Checking system Node.js version

Message: The version of Node.js you are using is not supported.
Supported: ^6.9.0 || ^8.9.0
Installed: 10.9.0

I tried: ghost update --force but it doesn’t do the trick… it says the same.
cli and npm are up to date .

Please tell me I don’t have to downgrade, avoid me that setup nightmare.

How can can I bypass the check?

Thank you


#2

Can you update your CLI version (sudo npm install -g ghost-cli@latest)? The latest version of the CLI added support for node v10.13+ (note your version of node is still unsupported, you need to update it)


#3

I already updated the cli version :confused:

Oh nvm, thanks, let me update the node then to the latest ghost supported version. Thanks

Edit: Oh well… I didn’t it was so easy with npm sudo n 8.9.0 I thought I had to run a nvm setup :smile:

Here is the list of the node versions

It upgraded smoothly, thanks @vikaspotluri123