OSX terminal issues preventing yarn/gulp install, so can't edit CSS

Hello folks, I hope you’re well and handling coronavirus lockdown well. I’m using this time to play with Ghost theme building, revisiting web dev for the first time in about seven years. Please bear with my newbie questions, which I’ll be asking a few of.

I’m running Ghost locally on my Mac (OSX 10.15.4), and tinkering with the Lyra theme with the view for a possible blog project. I’m working through the documentation and tutorials, and hope you may be able to advise on some sticky points.

Orienting myself to the theme code I find I cannot update CSS files. I’m not the first to ask about this, and have read the docs here: https://github.com/TryGhost/Casper#development

However, I cannot get yarn installed.

I had issues installing Node and Ghost, and was only successful after changing from zsh to bash. Tonight, following the above linked instructions, I tried yarn install in the ghost install dir, but get: yarn: command not found.
Entering brew yarn install, an installation was successful but suggested .profile needed updating - followed instructions and added it to my zsh profile, but yarn still isn’t installing. Changed shell to bash, but cannot find a bash profile to configure, and yarn install still doesn’t work.
I can see .yarn in my Users directory. Trying brew install yarn now times out. yarn --version, nothing. I’m getting to the limits of my terminal knowledge.

Are the instructions as above, requiring yarn and gulp, the only way to update CSS?

Otherwise I’ll keep bashing at the terminal and to try get it working.

Thanks in advance for your help!

It seems that yarn half installed, so deleted what I could and re-installed everything. Will leave this here in case anyone else has this issue!