"Please verify your email settings" what did I do wrong?


I am running a self-hosted instance of Ghost. We have all ports unblocked with our VPS, and our config file’s code is below:

  "url": "https://news.tleem.org",
  "server": {
    "port": [hidden],
    "host": "[hidden]"
  "database": {
    "client": "sqlite3",
    "connection": {
      "filename": "[hidden]"
  "mail": {
    "transport": "SMTP",
    "options": {
      "service": "Mailgun",
      "host": "smtp.mailgun.org",
      "port": 587,
      "auth": {
        "user": "noreply@news.tleem.org",
        "pass": "[hidden]"
  "logging": {
    "transports": [
  "process": "local",
  "paths": {
    "contentPath": "/home/cli/news/content"

However, when I try to invite someone to be a contributor, this error pops up in the bottom left corner of my screen:

Screenshot 2024-05-13 at 2.21.04 PM

Also, here is a screenshot of my Mailgun settings:

Closed. Turns out it was just a issue with Mailgun and our plan :)