Please verify your email settings

I tried to add my email address into Portal / Account Page / Support email address and I got this red error message: Please verify your email settings

I don’t know what this means?

Are you self-hosting or on a managed Ghost hosting service?

I took a quick glance at the Ghost core and it looks like the error is thrown when Mailgun isn’t set up for newsletter sending.

Ah ok, that could be it. Self hosting. It would be great to update that error message to make it more useful… For instance
“Please add Mailgun before updating this setting”

I added mailgun yet I still get the same error message when adding the support email. What am I doing wrong?

Given the new topic you started, I assume that the transactional email setup could also have an effect on it.

I’d suggest following the steps in the config documentation and trying again then.

1 Like

Let’s continue at the new topic then

Hi all, I’m having the same problem hosting Ghost on PikaPods.

I migrated my site from Digital Ocean, where I sent newsletters using Mailgun with the subdomain mail. domain. com (Mailgun recommends using a separate subdomain for sending bulk mail) but used myname@domain. com as the sender address and reply address (that address is also set up through Mailgun).

On PikaPods the sender email address defaults to noreply@domain. com. When I try to change it to myname@domain. com, I get the same error “Please verify your email settings”.

I have not changed any settings on Mailgun and copied and pasted the same settings for PikaPods’ “environment variables” as the what was in the config.json file on the old server.

Also I sent an email newsletter after I moved to PikaPods and everything seemed to work fine sending through the new setup, just from noreply@domain. com instead of myname@domain. com.

Any ideas on why Ghost is giving this error message and not allowing me to change the sending/reply email address?

Could be due to the new server environment, I guess? Have you tried to verify your email again?

Honestly, the only good thing I could suggest is migrate away from pikapods and go to railway. That’s what I did. Just too much problems with pikapods. No support for their pods either just generic hosting support. Railway has an active discord community and I was helped out several times with my ghost install.

Have you set both the transactional as well as the bulk email settings on PikaPods? Can you share what environment variables you set there (remove any API keys or password)?

SMTP, not smpt? Check your spelling!


Well isn’t that just the most embarrassing thing ever… thank you!

Just to make sure, I checked the sender email and it had already changed on its own just from fixing that one mistake.

It’s weird to me that I was still able to send the newsletter, but I guess this is a transactional setting, not a bulk mail setting?

Anyway, just happy it’s working now.

Thanks again!

(Hopefully this helps someone else out there.)

Glad you got it fixed! Yes, transactional and newsletter email are totally separate.

1 Like