Postmark SMTP for transactional email

I have trouble using Postmark SMTP for ghost. Ghost wants an email and password and SSL. But Postmark has username, password and TLS. How do I add postmark to my ghost variables?

Do I set secure false? Why doesn’t ghost variables support TLS?

Ghost does support TLS. The relevant section in your production.config.json should look something like this.

  "mail": {
    "from": "<from address>",
    "transport": "SMTP",
    "options": {
      "host": "<SMTP server>",
      "port": 587,
      "service": "Postmark",
      "secure": false,
      "requireTLS": true,
      "auth": {
        "user": "<username>",
        "pass": "<password>"
      }
    }
  },

Ah ok I see. On my railway ghost image the requireTLS variable does not show up. Maybe something I need to talk to the image creator about.

Question: TLS is secure so why set secure to false?

TLS is secure, but the initial handshake is not. SMTP always starts unencrypted, and the handshake determines what version of TLS is used.

That’s too technical for me :)

1 Like