Posts with Titles are being published with "untitled" URL

Issue Summary

I have 20+ draft blog posts that I created before the update to ghost 5.0. When I publish them, the titles are not being used in the URL for the blog post.

This was not happening with the draft posts I published before the update.

I do not have these set to auto-publish. I am manually publishing them so that I can proof read before they go live. I am checking they have titles, and even deleting and rewriting the title doesn’t make a difference.

When I publish, the URL is (e.g): Rock Roses, instead of https://www.colwynn.com/rock-roses/

Steps to Reproduce

  1. Select “Drafts” from dashboard
  2. Select blog post I wish to publish.
  3. Make edits after proof reading.
  4. Click “Publish”
  5. Click “Continue”
  6. Post is published with “untitled” URL.


Setup information

Ghost Version

  • Version: 5.2.3

Node.js Version
n/a

How did you install Ghost?
not self-hosted

Provide details of your host & operating system
Include further details about your hosting and OS.

Database type
n/a

Browser & OS version
Chrome, Ubuntu 20.04.4 LTS

Relevant log / error output
Copy and paste any relevant log output. Use backticks to format this into code.

It’s likely you / Ghost saved a draft post before adding the title, so Ghost created the untitled-n slug. So, go back to the published post to edit the post URL, and click update. You’ll need to click on the top-right ‘button’ to open Post Settings.


It’s a good idea to add the post title first to avoid this.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.