Problems with mailgun AND transaction emails

Hi

I am building a ghost website, so far has been working fine but now I am trying to intregrate Mailgun (as recommended) as SMTP provider bot newsletter AND transaction emails and I am having a hard time.
I’ve spent 2 days reading thourgh various post here and on the internet without finding a solution to my problem.

I run Ghost 5 on docker under OMV5 server.
I have configured mailgun in the docker compose file but I cannot find the config.production.json file that corresponds to my settings in the docker compose (via portainer)…
When I look in my container I can see all is there but the .json does not contains the same variables (database, posts etc) as I’ve set in the compose file. How come when the site is working fine (despite adding users and newsletters) and when I test email to a regestred user it does not work.
I find all info on the site very informative excepts the mailgun intregration, I am clueless.

I don’t know how to solve this, does anyone have a clue?

Does this help? It explains how to pass variables to the container. BTW, I don’t use Docker.

Hi and thanks but I already has this covered through ENV variables. It seems I have made a mistake forwarding mailgun to cloudflare…

I used the following guides and articles to solve problem and to take me this far:

https://felipecruz.es/creating-your-newsletter-with-ghost/
https://help.mailgun.com/hc/en-us/articles/360026833053-Domai
https://ghost.bavatuesdays.com/configuring-email-for-a-ghost-

I hope it will help somebody else. I think the Ghost wiki should have a link to the help article at mailgun, the DNS is hard to understand but that guide helped!

1 Like

Nice, glad you got it figured out. It is surprising the ghost docs don’t include more help around mail setup very far beyond “hey use mailgun.” But I recognize ghost staff are doing their best :)

I had an issue here with setup where cloudflare was blocking the ports required, so I’ve had to graycloud (disable proxy) it for now until I can pay for cloudflare spectrum which allows for port 587 (which mailgun uses)

The documentation is available, if you look for it; the OP was running Docker, which is community-supported only.

Cloudflare doesn’t block port 587. Indeed, calls to the Mailgun API or transactional mail (egress) won’t go through Cloudflare. I use both Mailgun and Cloudflare, and my transactional email uses port 587.

I suggest you open a new support thread rather than piggy-backing this one, and set out the issue in more detail.