Question about image used in post settings

Hi, I’m using the Caspar theme. If I go to a post and click the gear icon and open post settings, I get to choose an image that is assigned to the post, which is then displayed on my posts homepage or when I share to social media. That image too automatically gets inserted into the post, at the very top and is HUGE, the dimensions exceed the width of the text container.

Conversely if I remove the image from the post settings and simply insert the image into the post, that image is not pulled for display or social media sharing.

I’m curious if there is a snippet of code I can install to globally turn off the automatic insertion of the image into the post itself? So that I can select the image and insert it in post settings and have that image be used when sharing and when displaying on my homepage, but the image itself does not appear in the post, unless I insert it manually using the image feature.

Thanks so much,
Ken

Hey Ken,

The most straightforward and easiest way would be using CSS to hide the image if you don’t want to change the theme code. You can add this CSS in “Code injection > Site Header” field.

.post-full-image {
    display: none;
}

The only downside to this solution is that the image still gets downloaded in the background, it’s just hidden visually.

On the other hand, if you’re comfortable with editing theme code, you can comment out the featured image related code in post.hbs file.

2 Likes

Thanks for your response. I am comfortable editing theme code, when I know the specific code I need to update/change. Do you have any guidance in this regard, if I were to edit the post.hbs file?
Thanks so much for your response,
Ken

Here is the code (highlighted section if you click the link) you should comment out, or remove. It’s also linked in the previous reply, apologies if that was unclear :slightly_smiling_face: