Scheduled Post Permission Error

General Ghost info:

Hi all.

While post scheduling worked on Ghost v2, we’ve been running into this permission issue since moved to Ghost v3 a few months ago.

To give a bit more context, we weren’t able to upgrade from v2 to v3 using the Ghost CLI. Instead, we had to set up a new instance of Ghost and migrate the users from the original DB to the new one, and use the Admin API to seed in the existing posts and drafts.

Since doing the migration, we haven’t been able to schedule posts. When we check the logs, it seems like there’s a permission issue:

Ghost Doctor shows that everything is alright, and we’ve tried the file/directory permission fix suggested in the docs here for good measure. But the error seems to have something to do with an internal token being rejected for some reason.

Has anyone else run into this issue? Any suggestions would be greatly appreciated.

2 Likes

I have the same problem. It seems to be an issue using nginx proxy pass? to a url folder. have not gotten scheduling working in v3 and still looking for a solution.

1 Like

Hi @ghostusera, hope you’re able to work out your scheduling issues soon.

For use I don’t believe it’s an NGINX proxy pass issue – we have have several Ghost installations running on different VMs that we’re reverse proxying. One is Ghost v2, and the other is v3, but scheduling works fine for both of those. It’s just this installation that’s giving us some trouble.

1 Like

no i havn’t and i spent many hours. I have followed the directions completely. updated to the latest ghost as of this post and also the just recent recommended node.js update a day ago. Everything completely works except schedule with a permission error. If i input the put url it replies with 404 error that is handled by ghost. I also initiated a ghost reinstall numerous ghost restarts with schedule 3 minute test posts with nginx proxy settings and ssl options.

I’m thinking the token does have something to do with the fact the url is a subdirectory.

1 Like