Settings won't fetch

Hello, I tried to route my landing page to a different page, and it didn’t work, as my website says 404 error. I tried to redownload the file and make changes, but it won’t even let me upload a new file, it says “settings won’t fetch”, what do I do now?

FYI: I am a total beginner to any type of routing/coding/etc. so it will have to be really broken down to me

Welcome to Ghost!

When you say you changed your routing, do you mean you uploaded a new routes.yaml, or that you made changes to whatever proxy (nginx?) you have sitting in front of Ghost?

Uploading a weird routes.yaml shouldn’t actually stop you from getting to the admin pages. If you go directly to yoursite.tld/ghost/ , does that let you get into the server?

If you don’t mean that you uploaded a new routes.yaml, please explain in more detail what you did so that hopefully someone can help! :slight_smile:

You don’t say anything about proxying, but just in case:

  1. If you try to open yoursite.tld/ghost/ with dev tools (F12) open, are there any informative console messages?
  2. Are there any failures in the network tab?
  3. If you’ve turned on something like Cloudflare or made other changes to proxying/security, it’d be worth turning them off temporarily to see if the problem goes away. It’s really easy to mess up URL rewriting with Cloudflare, and that can cause a lot of problems with the admin panel.