Smtp with ionos

I’m trying to use smtp with my domain/webspace provider. I see mailgun is the only thing that can be used for newsletter but i dont think the user sign up is part of the bulk mail functionality. I’m getting this error when the “failed to send magic link” message is posted
It looks like this is the call that throws the error
INFO “POST /members/api/send-magic-link/” 400

550 invalid DNS MX or A/AAAA resource record.

Failed to send email. Reason: Mail command failed: 550-Requested action not taken: mailbox unavailable
550 invalid DNS MX or A/AAAA resource record.

I am only testing locally with my servers ip before i set up my nginx and public facing url, however i do get the verify email address email when i edit the from address in the newsletter. im not sure what the difference is between a new user subscribe or setting the from address in the newsletter, assuming some sort of verification but this page indicates that new user sign ups fall under the transactional email. if the newsletter test that is being done can send email i’d assume the other transactional methods should work as well.

when a user tries to subscribe, is it trying to check the mx records of the local transactional email config and server or the user that is signing up? i tried to signup with both my own domain and a gmail address and got the same thing.

my config mail settings

  "mail": {
    "transport": "SMTP",
    "from": "'xxxxxxxxxxx",
    "options": {
      "host": "",
      "port": 587,
      "secure": false,
      "requireTLS": true,
      "auth": {
        "type": "LOGIN",
        "user": "xxxxxxxxx",
        "pass": "xxxxxxxx"

Transactional email is provided by SMTP. If you’re using Mailgun for bulk mail, you can use their SMTP service for transactional email.

The issue is likely because you’re using an IP and not a FQDN with Ghost. If you’re running Ghost on the server use the domain name, and set the instance as private, so it’s neither accessible nor crawled by search engines.

Typically, your domain will have MX records pointing to either Mailgun or your hosts SMTP servers.

1 Like

I went ahead and configured my nginx, which i wanted to wait until i got everything working but jumped on that anyway since it seemed like a valid test to rule out. looks like now im getting a 500 on the form send

[2023-02-20 17:13:55] ERROR "POST /members/api/send-magic-link/" 500 425ms

Failed to send email. Reason: Sending failed.

"Please see for instructions on configuring email."

Error ID:


Error: Sending failed
    at createMailError (/var/lib/ghost/versions/5.35.0/core/server/services/mail/GhostMailer.js:68:12)
    at DirectMailer.<anonymous> (/var/lib/ghost/versions/5.35.0/node_modules/nodemailer-direct-transport/lib/direct-transport.js:157:41)
    at DirectMailer.<anonymous> (/var/lib/ghost/versions/5.35.0/node_modules/nodemailer-direct-transport/lib/direct-transport.js:228:30)
    at /var/lib/ghost/versions/5.35.0/node_modules/nodemailer-direct-transport/lib/direct-transport.js:350:28
    at callback (/var/lib/ghost/versions/5.35.0/node_modules/smtp-connection/lib/smtp-connection.js:374:14)
    at SMTPConnection.<anonymous> (/var/lib/ghost/versions/5.35.0/node_modules/smtp-connection/lib/smtp-connection.js:385:20)
    at SMTPConnection._actionMAIL (/var/lib/ghost/versions/5.35.0/node_modules/smtp-connection/lib/smtp-connection.js:1252:16)
    at SMTPConnection.<anonymous> (/var/lib/ghost/versions/5.35.0/node_modules/smtp-connection/lib/smtp-connection.js:759:14)
    at SMTPConnection._processResponse (/var/lib/ghost/versions/5.35.0/node_modules/smtp-connection/lib/smtp-connection.js:669:16)
    at SMTPConnection._onData (/var/lib/ghost/versions/5.35.0/node_modules/smtp-connection/lib/smtp-connection.js:493:10)
    at TLSSocket.emit (node:events:513:28)
    at addChunk (node:internal/streams/readable:315:12)
    at readableAddChunk (node:internal/streams/readable:289:9)
    at TLSSocket.Readable.push (node:internal/streams/readable:228:10)
    at TLSWrap.onStreamRead (node:internal/stream_base_commons:190:23)

however i was able to fix that … im going to leave the above since i had already typed it for if anyone comes across this post in the future
my config had somehow changed since last i posted it and it got changed to Direct for the transport method, changed it back to SMTP and it seems to be working now. so i think setting up nginx fixed the initial problem, which somehow lead to another which i also fixed.

1 Like