Some blog post tags give 404 error

I have created a sorting system using tags and it was working great. But one day I came back to continue to work on content management so that user could input their own data for some page elements. Then I noticed that some site posts could not be opened leading to a 404 page. I did some testing and found out that posts with some specific tags would lead to 404 page, but when i change out to a different tag the page would work and load properly.
Here is a link to the video for the problem
Explanation of the video:
first I have a blog post created. Than I add t tag “Glosas” by using the tag the post is placed in the page “Glosārijs”, then I go to the page “Glosārijs” there the new post is found. i click on the post it leads to 404 page. After that I change the tag of the same post to “Metodes” that moves the post to the page “Metodes”, after I go to the page and try to apen the post and it opens correctly. Then a change the tad back to glosas and find it in the appropriate page it has been found and when opened shows 404 again, after i ad metodes tag to it and it is also found in the metodes page, but leads to 404 page because it thas the tag glosas on it. As i understand its something to do with the specific tag.

I have tried to remove tag and add it again but didn’t help. I checked all of the routes but they haven’t changed. This worked perfectly yesterday.

1 Like

This just happened to me while using Ghost(Pro). It only happens with posts using a tag that I have excluded from the homepage via routes.yaml. The post thumbnails and headlines are shown on the corresponding tag page, but links to those posts go to hashed URLs which do not work. Even manually entering the clean post URLs present 404 errors. It worked fine for weeks without me changing anything but today suddenly presents this problem. I removed the routes.yaml filter as a band-aid and the posts returned, but I would really rather exclude them from appearing on the homepage.

Any ideas?