Tags go to 404 page

Issue: all tags lead to 404 page. Tried deleting all tags and re-creating them, remove and add back to blog posts - not working. No slug appears on the main Tags page, although they’ve been added in Tags > Advanced. For example slug is “advanced” and URL displaying below is "www.gdprstart.com/tag/advanced/ " but it goes to 404.


Appreciate any help!

    • What version of Ghost are you using? Latest (just got started).
    • How was Ghost installed and configured? Ghost Pro, alto theme, deleted ghost default profile (which then deleted all default blog posts, but not the “Getting started” tag).
    • What Node version, database, OS & browser are you using? Mac Monterey latest version, Firefox
    • What errors or information do you see in the console? Not sure what to answer here…
    • What steps could someone else take to reproduce the issue you’re having? Go to any blog post and click on a tag. When hovering over any tag on the page, you can see they all lead straight to 404.

Hello @gdprgeek this is a frustrating bug in Ghost. I’ve had this bug happen with me.

Here’s what I do:

  1. I create the tag
  2. It creates a 404 link.
  3. I go to an article and at the new tag to it.
  4. The link starts working.

In your case, I see you have a page already with the “Advanced” tag but it still doesn’t work. So, I suggest you:

  1. delete the “Advanced” tag
  2. Create a new “advanced” tag
  3. Add it to a couple of posts
  4. Pray…

If it still doesn’t work talk to Ghost Pro support since you are a paying customer. They will help you

Thanks for the suggestion @Tiago, unfortunately this doesn’t do the trick. Thought I’d post here in case someone had a solution and others may encounter the same issue. Will email Ghost and update here later. :slight_smile:

1 Like

Analysis and solution, courtesy of the awesome Ghost support team:

When reviewing your site, it looks like you’re running a custom routes.yaml file, which doesn’t include the base configuration – e.g. the setup that gives tag archive pages their path on the site. The easiest fix for this would be to login to Ghost Admin, and upload the base configuration back to the site, in the Settings > Labs area (under “Routes”).

And here is the config, which did indeed solve the issue! :point_down:


    permalink: /{slug}/
    template: index

  tag: /tag/{slug}/
  author: /author/{slug}/
1 Like