'Something went wrong :(" when importing theme

I have a local install of ghost where I edit my theme every now and then.

I have been doing this for a couple of years now, with no problem at all.

Now when I try and download a theme from production server and import into my local development area, I get a “Something went wrong :(” message.

Nothing has changed locally.
Both servers are running same version of Ghost.

I have even tried importing versions that I 100% know have worked in the past. Absolutely nothing works.

I have tested the themes and no major warnings appear using the theme checker tool.

Please help!

Can you check and paste here the error logs on the server when the theme upload fails? The logs can be watched through ghost log command or by tailing the logs located by default in content/logs, so you can run tail -f ./content/logs/*.log

Thanks for your fast response. I actually managed to solve it.

  • reinstalled basically everything
  • updated node, npm, cli
  • forced a reinstall of same version

It worked nicely. I’ll make sure to check logs if I hit any errors!