Spell check on wrong language

For some reason when i am writing a page or a post at Ghost, the spell check is configured to Spanish instead English.

I already choose en at general configuration on the admin panel , and can’t find any other settings regarding spell checking or language.

Any idea why is this happening?

Thanks in advance =)