Support email address - cannot change, no confirm. link

Hi,

I just set-up Mailgun, sending emails works well. However, when I change the support adress (see picture) I do not receive any confirmation email (even though the green notification appears telling me to click the link). Can someone please help? It’s a self-hosted DO droplet.

I have the same problem.

Tells me to “Check your inbox and click the link to confirm”. But there’s no email. I’ve also checked in the spam folder.

1 Like

I have the same problem? does anyone know how to fix this?

same here. did you fix this?

I am in the process of setting this up (also DO droplet). I’ll keep you posted.

Has anyone figured this out yet? It’s pretty important that subscriber responses actually go somewhere you can read them…

No, not yet. I didn’t even get the welcome email after the installation, but the mailgun setup works for sending out emails.

I apologize for tagging dev team members directly, but we all need some troubleshooting steps to follow here.

I for one have successfully set up MailGun, I got the correct domain name according to MailGun support and I am using the correct MailGun API key and when testing the email send-out to myself as a test member – it all works.

That said, I am still unable to change the support email address. It gives me a green arrow indicating that a confirmation email has been sent, but no email is received. Not even in the spam folder.

Furthermore, I have edited the config.production.json file with the MailGun settings for SMTP and as explained, sending out emails when publishing posts works fine.

Not sure what or how to further troubleshoot this. Perhaps @Kevin can be so kind and assist?

Solved.

It’s a matter of MX. if you add Mailgun MX to your DNS, then the confirmation email goes to Mailgun and you need to set a route to have it delivered to you.

Alternatively, you can set a different MX for your account, while keeping the other records from Mailgun (TXT and CNAME if I remember correctly). This way, you’d be able to send messages from both the accounts (say Gmail and Mailgun) and receive to the ine you set the MX (say Gmail).

1 Like

@sigul ah, okay. I have to check my MX records on namecheap then. Think I did add one, but I think its for the mailgun generated address that sends out logins and what not.

Problem for me is this; protonmail does not offer this for free.

You can try zohomail - they have a free tier that is working for me. Scroll down a bit on this page to see the zohomail forever free plan.

I am having the same problem. I tried deleting the MX records that I had set in digital ocean for mailgun, but it’s still not working and it’s been over 24 hours. Does anybody have any suggestions for other problems that might be causing this?