Can't change Sender Address in newsletter settings

I tried searching the forums, but all the proposed solutions I found so far, don’t seem to work in my case.

I moved from Ghost(Pro) to a self-hosted solution on digitalocean and have set up Mailgun to send out emails for my newsletter. All of this seems to work, and I can send emails successfully and all.

However, I can’t seem to change the email address away from noreply@my-domain to anything else. As soon as I click on “Save & Close”, it just tells me to retry with the button turning red. No error message whatsoever.

I’m a bit at a loss here.

Following SMTP Process using Mailgun will solve the problem.

Step 1: Download FileZilla.

Step 2: Connect Server with SFTP
User: root
Host: Your Droplet IP (123.43.433.33)
Password: (As you set)

Step 3: Once connected, go to the main directory and locate var/www/ghost

Step 4: Open and Edit the config.production.json file.

Step 5: Restart Ghost using terminal

Retry the email change from Ghost Dashboard.

Tada, you will get popup of confirmation email.

Updated to 5.15.0

My ghost install is sending emails (confirmed by creating a staff user invite, all received fine, json file is in order)
When I try to add a Sender email address within Edit Newsletter section I am show the - Confirm newsletter email address popup, but no email arrives and so reply-to email cannot be changed?

Has anyone experienced this or any ideas for a solution?
Thanks

I am experiencing the same issue with Portal Settings > Account page settings > Support email address - When I make a change to this, I am shown the confirm email address (we’ve sent a confirmation email to xxx, until verified support will remain noreply@) Same issue, no email is received.

I can however send staff membership invites to the same email sent and received with no problems.