"the website contains content that is not secure" browser warning

  • What’s your URL? This is the easiest way for others to debug your issue
  • What version of Ghost are you using?
    2.11.1 (Upgrading to 2.12.0 today though)
  • What configuration?
  • Version 2.11.1
  • Environment production
  • Database mysql
  • Mail Direct
  • What browser?
    Firefox 64.0.2
  • What errors or information do you see in the console?
    I have a valid HTTPS certificate applied to my site, but it shows that some content is not secure. I’m not sure what content is not secure or how to make it secure on my ghost server.
  • What steps could someone else take to reproduce the issue you’re having?
    Go to my site in your browser.


Your URL is configured as htttp in ghost - you need to update it by running ghost config set url https://infosec.theos-blog.com and then running ghost restart in your installation directory

AMP links to our IP address

Super @vikaspotluri123! Thanks so much. It’s working fine now.

userx@ghost-new-s-1vcpu-2gb-nyc1-01:/var/www/ghost$ ghost config set url https://infosec.theos-blog.com
Successfully set 'url' to 'https://infosec.theos-blog.com'
userx@ghost-new-s-1vcpu-2gb-nyc1-01:/var/www/ghost$ ghost restart
+ sudo systemctl is-active ghost_infosec-theos-blog-com
? Sudo Password [hidden]
+ sudo systemctl restart ghost_infosec-theos-blog-com
✔ Restarting Ghost


Do I have to “close” answered questions here?


Nope, topics will be automatically closed in 2 weeks, or by a moderator if they decide it’s necessary!


Hi @vikaspotluri123, or anyone else who may be able to help.
The issue is back. :frowning:
I tried the same fix again, but it has not gone away.
Just to make sure it wasn’t a cache issue, I tried in Chrome and get a similar error.
Same info as before, but running Ghost 2.12.0 now.
I’ve my profile under Team, but don’t think I’ve done anything else.
Please let me know if there are any logs or config files I can send that may help.
Kind regards,


It looks like you need to re-upload any images you added before fixing the url -

http://infosec.theos-blog.com/content/images/2018/01/Ted-Eiger.jpg (header)
http://infosec.theos-blog.com/content/images/2018/01/cup-of-coffee-1280537_1920.jpg (background image)

Re-uploading those 2 images should fix your issues


Great info @vikaspotluri123, and I’ve uploaded the files, but still have the issue. How did you find those to be problem files so quickly? More importantly, how might I? Teach a man to fish… :slight_smile:


Could you double check that your blog cover and icon are being loaded over https?

Great question! It’s a combination of experience (knowing why something is where it is) and looking at the page source: view-source:https://infosec.theos-blog.com/ in Chrome


@vikaspotluri123, I do see them on the page which is supposed to be loading over HTTPS. I’m not sure how to check whether the images are uploading over HTTP or HTTPS though.

Thanks for the info on how you found it.


My images folder doesn’t look like it has anything in it except those two files. I may have to retrieve some stuff from my old server.
I built this one from scratch and used the .json backup to create the posts.


There’s your issue :stuck_out_tongue: So the reason the images are loading as http is because Ghost stores images as absolute paths (e.g. https://my.site/path/to/image rather than /path/to/image). The easiest way to update the path is to re-upload the image so Ghost saves the path with https


OK @vikaspotluri123, I’ve zipped the directory on the old server, SCPed it to the new server, put it in place and changed ownership recursively on the files. I do have a 2016 and 2017 folder from the old server, but it looks like it’s searching for everything in the 2018/01 folder. Do I have to copy all the content there for this to work on the new server?
You can’t be on here 24x7 so I hope you’re getting some sleep or something. I’ll let you know how it goes.


Getting my dates mixed up. I now have a 2019 folder, which is new, along with a 2017 and 2018 folder. It should be looking for stuff in the right places.


@vikaspotluri123 I think I’ve got it. I had some files that didn’t have the right ownership. Changed them recursively again, restarted ghost, and it seems to be working now.
Incidentally, what forum software is in use here? It seems pretty cool and Ghost-like.


Congrats on getting it to work!

Running ghost doctor should help you discover any permission issues you run into in the future :slight_smile:



Thanks yet again @vikaspotluri123. Ghost doctor found some more permission stuff, so I ran the suggested commands and it runs clean now.

However, the issue is back. Still getting the mixed content message.

Discourse looks like cool Forum software. I’ll check it out.

Kind regards,



Just to be sure, you re-uploaded any images you uploaded, correct?

If you don’t re-upload them, some of the urls won’t update.


@vikaspotluri123, I deleted the images for my profile for now, and it’s working.
How often will I have to re-upload those to keep from having errors?
Kind regards,