Trying to add developer and they can't accept the invite

I am trying to add a 4th admin user to my Ghost Staff page and the developer is having issues accepting the invite.

They put together this loom showing their issue: Loom | Free Screen & Video Recording Software | Loom

I tried revoking and resending the invite and that didn’t work. I also tried inviting another developer on their team and that didn’t work either.

Any ideas as to how to fix this and get the developer admin access?

  • What’s your URL? This is the easiest way for others to help you Reventure Consulting
  • What version of Ghost are you using? version 5.52.3


  • How was Ghost installed and configured?
  • What Node version, database, OS & browser are you using?
  • What errors or information do you see in the console? white screen takes over when they accept the invite, and then errors pop up related to “failed to lead resource: too many redirects”
  • What steps could someone else take to reproduce the issue you’re having? i wonder if the issue has to do with the number of developers? There was never this issue when adding admin access to developers 1 through 3. Additionally could their location also be playing an issue? The developers receiving the error are in Pakistan while the others were in America.

I’d check first the nginx config… as it’s saying too many redirects.