Twitter cards not showing up in newsletter


I have a self-hosted blog and using Mailgun for develiry of the newsletter. It worked fine for more than a year but encounted an issue starting Feb/March. The tweet cards are rendered fine in the validator but upon posting the tweets are shown as text only in the newsletter and not as cards. I also noticed today that when I open a draft post where I have tweets, it takes about a minute for the card to show up. Any ideas or suggestions what could be causing this ?


I had a similar problem with Twitter. Then I realized that the problem is only local to me because of my browser’s ad blocker. It was solved by checking in another browser where I don’t have ad filters.


Thanks for the suggestion. My problem was that the cards didn’t render in the newsletter but they appeared as text only. I tried again today and it seems to be working fine. Not sure what the issues was back then, sorry, I only found sending email option in the preview after I posted here.