Unsubscribe button different links

I tried to send a test newsletter to myself.
In the email footer I have two unsubscribe buttons, as you can see in the img.

The buttons are associated with different links.

The first link takes me to my blog, as the page title is written “Unsubscribe Failed

The second link takes me to an empty page, which at the end of the load is empty with ERR_CONNECTION_TIMED_OUT error

ghost version last
config default

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you:

  • What’s your URL?
  • What version of Ghost are you using?
  • What configuration?
  • What browser?
  • What errors or information do you see in the console?
  • What steps could someone else take to reproduce the issue you’re having?

Thanks! :blush:

Url: private
Ghost version: last
Configuration: default
Browser: All
Error: no console errors
Steps: Post - Settings - Email Newsletter - Test Email - Check your Inbox

Please provide the information properly, “last” and “default” aren’t helpful. The Ghost version number is what you’re meant to share, plus your configuration (with sensitive details redacted).

It would also help to know what email client you’re using, as I suspect it’s creating an extra “unsubscribe” link at the bottom of your emails for your convenience. Or possibly Mailgun is adding it in for you?

Seems like a duplicate of

You’re right I apologize.
This is the version of ghost and its configuration:

  • Version 3.22.1
  • Environment production
  • Database mysql
  • Mail SMTP

This is the config.production.json file:

  "url": "https://domain.it",
  "server": {
    "port": 2368,
    "host": ""
  "database": {
    "client": "mysql",
    "connection": {
      "host": "localhost",
      "user": "ghost-***",
      "password": "******",
      "database": "ghost_***"
  "mail": {
    "transport": "SMTP",
    "options": {
      "service": "Mailgun",
      "host": "smtp.eu.mailgun.org",
      "port": 465,
      "secureConnection": true,
      "auth": {
        "user": "postmaster@mg.domain.it",
        "pass": "*************"
  "logging": {
    "transports": [
  "process": "systemd",
  "paths": {
    "contentPath": "/var/www/ghost/content"

Under the item Email newsletter settings from the admin panel of Ghost, as Mailgun Domain I set: mg.domain.it with the Mailgun API key.

As a mail client I use Mailspring. But I tried to open the email with GMAIL too, I have the same problem.

Indeed this setting was active. I disabled it and tried to send a new email. I still have the same problem. Is it possible that the setting takes time to propagate? It seems strange.

I had the same problem, but this was fixed some time ago:

I hope I have given enough information, if not, ask me what you need, thanks


make sure you turned off Unsubscribes in Mailgun on the live domain, not the sandbox domain (that’s what i did last time -_-’…)
Also Open Tracking and Click Tracking can screw up the newsletter mail, try turning off all three.
Other than that, the change in mailgun should reflect immediately on the next mail.

thanks for the suggestion, I made the change on the main domain, I disabled everything.
Now it works, I just tried again, probably the change was propagated after a few minutes, maybe I tried again too soon.

So to solve this problem you have to disable the unsubscribe option on Mailgun

Mailgun -> Domain Settings -> Tracking - Unsubscribes Off

Glad it works now! :+1:

Thank you, but I had already changed the settings on the main domain, I had not changed the sandbox. In my opinion, my problem was only to test too quickly after changing the tracking function from the main domain.