Mailgun link and subscription issue

This is what’s going on:
two different links in the email, one in the button, the other at the bottom:

It seems to me that everything is configured correctly.

If I click on the link in the email below, the registration works correctly, if I click on the button it goes to the link with the prefix email. and after a while it times out.

What did I do wrong?
Thanks

Some news? Only I have this problem?

EDIT
config.production.json:

"mail": {
  "transport": "SMTP",
  "options": {
    "service": "Mailgun",
    "host": "smtp.eu.mailgun.org",
    "port": 465,
    "secureConnection": true,
    "auth": {
      "user": "postmaster@mg.******.it",
      "pass": "**************"
    }
  }
},

Can you please share your mail config (excluding the password) from config.production.json?

thats it

"mail": {
  "transport": "SMTP",
  "options": {
    "service": "Mailgun",
    "host": "smtp.eu.mailgun.org",
    "port": 465,
    "secureConnection": true,
    "auth": {
      "user": "postmaster@mg.******.it",
      "pass": "**************"
    }
  }
},

Feedback from the staff would be interesting

I’m surprised I haven’t had a hit yet, I think it’s an important bug

Hello, I would like to know at least if it is my personal problem I have to investigate, or it is a Ghost bug.

Thank you

I’ve tried on both local and production sites, but couldn’t reproduce the issue. Which version of Ghost are you using?

I am experiencing the same problem on two different installations, on two different servers. Only the mailgun account is the same.

Server 1 - Ghost version: 3.13.1
Server 2 - Ghost version: 3.12.1

Updated my instance to 3.13.1 and still couldn’t reproduce the issue. Have you made any change to the Ghost core code by any chance?

no, I haven’t changed anything at all.

Hello staff?

Having a similar problem for the magic link. The button is providing a different link → email.mail.domain.com/c/ vs. what we see right below the full link which is… domain.com/?token

Glad to know someone has my same problem.
At least I understand that it is not a problem due to my configuration.

I hope to receive feedback from the staff soon. I’m stuck with the 20 days member function.

It looks like you have to disable button tracking:

2 Likes

Thanks Vikas - yes, that did the trick! I hope we get Ghost Analytics for this sort of stuff soon.

thank you so much
the problem is solved in this way.