Upgrade from 1.22.3 to 1.22.5 - Theme issues

I want to upgrade from 1.22.3 to the v2 series… ‘ghost update’ insists that I upgrade to the latest 1.22.5 first…

Issue #1: upgrade recommends ‘npm install -g ghost-cli@latest’ - this fails with

npm ERR! Linux 4.9.0-8-amd64
npm ERR! argv “/usr/bin/node” “/usr/bin/npm” “install” “-g” “ghost-cli@latest”
npm ERR! node v6.14.4
npm ERR! npm v3.10.10
npm ERR! path /usr/lib/node_modules/ghost-cli/node_modules/ansi-align/node_modules/is-fullwidth-code-point
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall access

npm ERR! Error: EACCES: permission denied, access ‘/usr/lib/node_modules/ghost-cli/node_modules/ansi-align/node_modules/is-fullwidth-code-point’
npm ERR! at Error (native)
npm ERR! { Error: EACCES: permission denied, access ‘/usr/lib/node_modules/ghost-cli/node_modules/ansi-align/node_modules/is-fullwidth-code-point’
npm ERR! at Error (native)
npm ERR! errno: -13,
npm ERR! code: ‘EACCES’,
npm ERR! syscall: ‘access’,
npm ERR! path: ‘/usr/lib/node_modules/ghost-cli/node_modules/ansi-align/node_modules/is-fullwidth-code-point’ }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

So the instructions should be changed to ‘’‘sudo npm install -g ghost-cli@latest’’’

Issue #2: ‘’‘ghost update --v1’’’ fails to restart blog

:heavy_check_mark: Checking content folder ownership
:heavy_multiplication_x: Restarting Ghost
A ProcessError occurred.

Message: EACCES: permission denied, open ‘/var/www/normus.totahi.com/config.production.json’
Exit code: EACCES

Debug Information:
OS: Debian, v9.5
Node Version: v6.14.4
Ghost-CLI Version: 1.9.4
Environment: production
Command: ‘ghost update --v1’

Looks like a missing sudo again, because ‘’‘sudo systemctl restart ghost_xxx-xxx-xxx’’’ works.

Issue #3: Blog now shows: 500 - The currently active theme “bleak-master” is missing.

Ok - so I will switch back to Casper and get themes working later… but how?

Under Settings -> Design -> Themes it says ‘no themes found’ and there is no option to revert to Casper…

How can I reset the Theme to the default?


ok - so it seems the Casper theme is not installed properly as part of the upgrade.

So I did the upgrade to V2 anyway - with fingers crossed.

I was still getting a 500 - theme-missing error… so I found the casper theme here: GitHub - TryGhost/Casper: The default theme for Ghost and installed and activated that - and I’m back in business.

My conclusion - upgrades are always fraught.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.