"You need to configure Mailgun in Labs to enable email newsletters."

I am self-hosting the latest version of Ghost. I’ve turned on members in labs. Did not connect stripe because I don’t intend on using paid memberships yet. Left the default pricing. Allowed free membership signup. The default post access is public. Left the “from address” as default. I’ve set the correct Mailgun domain and APIkey. I’ve configured the SMTP settings in config.production.json.

I am able to subscribe new members using the subscribe button/forum. Though when viewing a new or existing post -> settings gear -> email newsletter, I am prompted with this error:
I can not send a test email and the inputs seem to be locked and darkened.

What do I do to get around this?

What version of Ghost are you on?

Did you ever upgrade to 3.22.0 exactly? If you did you may have lost settings - the solution to which was to rollback and restore from backup/reenter settings, then upgrade.

If you didn’t upgrade to 3.22 and are not on latest, please upgrade.

Then please open labs -> members, check your email configuration and hit save.

If none of this helps, please connect to your database and check the output from the query

select * from settings where `group` = 'email';

Please share the output, but redact your API key.

I am on version 3.25.0.

I’ve started using Ghost very recently. From what I assume purely based on the date after running “ghost install” and “ghost upgrade”, I just started to use 3.21.0. A couple of days ago I upgraded to 3.24.0. Just hours before this post I upgraded to 3.25.0.

I never upgraded to 3.22 specifically.

This is my output from the query:

Running the query Hannah supplied above, I supplied “https://api.mailgun.net/v3” as the value for the mailgun_base_url key.

This has also been reported here: Email Newsletter

Looks like a Ghost bug. We are looking into it.

1 Like

We’ve raised an issue here https://github.com/TryGhost/Ghost/issues/12052 and will be working on fixing this ASAP :relaxed:

If you have encountered this problem, please see the issue for confirmation it’s the same thing and a workaround until a fix is released!

1 Like

Throwing the workaround on here because it worked fine for me, and it is pretty easy to do, but most people may never click on the github link.


1.Open “Email newsletter settings”
2. Set “Mailgun region” to “EU”
3. Set “Mailgun region” back to “US”
4. Click “Save members settings”


This solved my issue. Thanks @LBacaj

I’ve having this issue from upgrading from v3.10 (ish) to v3.42 and then v4.01.

However, the workaround doesn’t work - I cannot see any settings in Email Settings. mailgun_base_url is getting set to null, even if I delete that key in the database.

I’ve tried setting those values manually, but the settings area is still not showing up.

@jhand this is a new and completely different issue - please could you open a new help thread and share as much information as possible about your setup? Thank you!

Update here: Settings > Email newsletter showing blank page