Zapier trigger never work

Hello, sorry to come and disturb you with this but I don’t know where to look.

My zaps are not triggered because the triggers are not launched when a post is published. All the configuration is good according to Zapier and the connection to ghost is in success. It does detect an example post during configuration.

I’m on the latest version of ghost, 3.15.3, but I did have the same problem in 3.x. Deployed via docker, with letsencrypt for SSL and apache in reverse proxy.

The configuration has not changed since the old versions which worked without worries (don’t remember release number)

I tested calls on the API via postman by making a custom integration and no worries.

can be a configuration reverse proxy side? but I don’t see any reason. If someone has an idea :thinking:

@pierre_brisorgueil do you have anything in your Docker/hosting setup that may be stopping Ghost making external requests?

One quick way to test this could be pasting a YouTube URL into a new paragraph in the editor, if external requests are working then it should automatically convert into an embed card.

hello !
thx you for reactivity, this gives me a track! it doesn’t work no, but it worked before, I have some videos posted

I’m going to look on this side, if someone has an idea, here are the confs

<VirtualHost *:80>
    ServerAdmin xxxx
    ServerName xxxx
    ServerAlias www.xxxx

    RewriteEngine on
    RewriteCond %{SERVER_NAME} =xxxx [OR]
    RewriteCond %{SERVER_NAME} =www.xxxx
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

<IfModule mod_ssl.c>
<VirtualHost *:443>
    ServerAdmin xxxx
    ServerName xxxx
    ServerAlias www.xxxx

    ErrorLog "/var/log/apache2/xxxx/error.log"
    CustomLog "/var/log/apache2/xxxx/access.log" combined

    RequestHeader set X-Forwarded-Proto "https"

    ProxyPreserveHost On
    ProxyRequests Off
    ProxyPass / http://127.0.0.1:5000/
    ProxyPassReverse / http://127.0.0.1:5000/

    <Proxy *>
        Order deny,allow
        Allow from 127.0.0.1
    </Proxy>

    RewriteEngine on
    RewriteCond %{DOCUMENT_ROOT}/%{REQUEST_FILENAME} !-f
    RewriteRule .* http://127.0.0.1:50000%{REQUEST_URI} [P,QSA]
    # needed for downloading attachments

    Include /etc/letsencrypt/options-ssl-apache.conf
    SSLCertificateFile /etc/letsencrypt/live/xxxx-0001/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/xxxx-0001/privkey.pem
</VirtualHost>
</IfModule>

docker part

  ghostWaos:
    container_name: xxxx
    image: ghost:latest
    restart: always
    ports:
      - 127.0.0.1:5000:2368
    volumes:
      - ghost:/var/lib/ghost/content
    environment:
      - url=https://xxxx

volumes:
  ghost:

I don’t know a huge amount about docker but I don’t think those configs will be where your problem lies. You should look into your bridge network setup to make sure your containers can access the outside world or possibly into any firewalls you have set up.

1 Like

Yep probably beetween iptables and docker, I’m looking on this, my actual conf was :

iptables -A FORWARD -i eth0 -o docker0 -j ACCEPT
iptables -A FORWARD -i docker0 -o eth0 -j ACCEPT

if I found a solution i will post here

hum always stuck for the moment, I think I miss something.

for information, docker iptables are disabled, I don’t like the fact that docker writes in iptables.

so : nano /etc/docker/daemon.json

{
  "iptables": false,
  "ip-forward": true
}

i have found informations like this : https://blog.kalrong.net/en/2017/05/16/iptables-for-docker-in-an-internet-exposed-server/ (but doesn’t work for me)

actually this work

iptables -A FORWARD -i docker0 -o eth0 -j ACCEPT
iptables -A FORWARD -i eth0 -o docker0 -j ACCEPT
iptables -t filter -A FORWARD -i eth0 -j ACCEPT
iptables -t filter -A FORWARD -o eth0 -j ACCEPT

but not a good solution, I will try to work on this later :slight_smile:

if someone have an idea !

thx for all

1 Like