Zoho Mail 535 Authentication Failed

I am using Ghost 3.5 hosted on Digital Ocean. I am using smtp through Zoho with two factor authentication turned off.

I am getting a 535 Authentication Failed Error when trying to “Invite People”. However, I ran OpenSSL on my DigitalOcean console and I was able to connect. The Authentication also worked.
OpenSSL>s_client -connect smtp.zoho.com:465
OpenSSL>ehlo Zoho.com
OpenSSL> Auth login
OpenSSL>(base 64 equivilent of my username)
OpenSSL>(base 64 equivilent of my password)
235 Authentication Successful.

Why am I getting a 535 error?
Is there something wrong with my config.production.json file (I used the same userid:password as the OpenSSL test)?
Do I need to install/configure something?
Thx
“mail”: {
“transport”: “SMTP”,
“options”: {
“service”: “ZohoMail”,
“host”: “smtp.zoho.com”,
“port”: 465,
“secureConnection”: true,
“auth”: {
“user”: “",
“password”: "

}
}
},

Hey @Bbianco,

Did set up Ghost using the official DigitalOcean droplet? Here’s a direct link:


You might want to check out the Ghost documentation on setting up mail servers as well:

…for example:

"mail": {
    "transport": "SMTP",
    "options": {
        "service": "Mailgun",
        "auth": {
            "user": "postmaster@example.mailgun.org",
            "pass": "1234567890"
        }
    }
}

Oddly enough with how the forum formatted the config you pasted, the problem is actually in bold :sweat_smile:

In your config: password should be pass

1 Like

It worked!!
You are a genius.I tried everything (OpenSSL, writing my own client etc) to solve the problem and all that was required was to change password should be pass.
Thanks

1 Like