About email newsletter subscription - Not working

I have recently installed ghost in my system and trying to enable email newsletter subscription. I am lost on the process to enable email newsletter subscription

the email newsletter subscription is just disabled. Waiting for the guidelines on solving this. When checking the html element, Enter your email is just a div without any textbox

Are you able to share the URL to your site? There’s a couple of different things that come to mind but it’s difficult to pinpoint without more info.

Hi Ryan, Thank you for the reply.

this is the blog in which i am trying to implement email newsletter subscription.

@shrawanlakhey you’ll need to set your site’s url config to the https URL. Currently it’s pointing at a http URL so the browser is blocking the requests used by the members feature due to security restrictions

Let’s try the easiest solution first. Can you confirm that subscriptions are enabled by going to Settings → Members → Sub access?

is this it? @TheRoyalFig

Thanks

Hi Kevin, Thank you for the response. I did tried to change the rul to https, but then after changing, it was redirecting to localhost and port url and not loading website. Then again i have to revert back to http.

Tell us more about your setup, i.e., hosting arrangements, and the instructions you followed. It may be helpful if you share your Ghost and Nginx config.

Also, be sure to clear browser cache and cookies when experiencing unexpected redirects. By the way, the portal pages are redirected too.

Hi @mjw i hosted the ghost in aws lightsail which is provided by bitnami,

below is my apacha configurations:

/opt/bitnami/apache2/conf/bitnami/bitnami.conf

# Default Virtual Host configuration.

# Let Apache know we're behind a SSL reverse proxy
SetEnvIf X-Forwarded-Proto https HTTPS=on

<VirtualHost _default_:80>
  ServerName nodexplained.com
  ServerAlias www.nodexplained.com
  DocumentRoot "/opt/bitnami/apache/htdocs"
  # BEGIN: Configuration for letsencrypt
  Include "/opt/bitnami/apps/letsencrypt/conf/httpd-prefix.conf"
  # END: Configuration for letsencrypt
  # BEGIN: Support domain renewal when using mod_proxy without Location
  <IfModule mod_proxy.c>
    ProxyPass /.well-known !
  </IfModule>
  # END: Support domain renewal when using mod_proxy without Location
  # BEGIN: Enable HTTP to HTTPS redirection
  RewriteEngine On
  RewriteCond %{HTTPS} !=on
  RewriteCond %{HTTP_HOST} !^localhost
  RewriteCond %{HTTP_HOST} !^[0-9]+.[0-9]+.[0-9]+.[0-9]+(:[0-9]+)?$
  RewriteCond %{REQUEST_URI} !^/\.well-known
  RewriteRule ^/(.*) https://%{SERVER_NAME}/$1 [R,L]
  # END: Enable HTTP to HTTPS redirection
  # BEGIN: Enable non-www to www redirection
  RewriteCond %{HTTP_HOST} !^www\. [NC]
  RewriteCond %{HTTP_HOST} !^localhost
  RewriteCond %{HTTP_HOST} !^[0-9]+.[0-9]+.[0-9]+.[0-9]+(:[0-9]+)?$
  RewriteCond %{REQUEST_URI} !^/\.well-known
  RewriteRule ^(.*)$ http://www.%{HTTP_HOST}%{REQUEST_URI} [R=permanent,L]
  # END: Enable non-www to www redirection
  <Directory "/opt/bitnami/apache/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
  </Directory>

  # Error Documents
  ErrorDocument 503 /503.html
  # BEGIN: Support domain renewal when using mod_proxy within Location
  <Location /.well-known>
    <IfModule mod_proxy.c>
      ProxyPass !
    </IfModule>
  </Location>
  # END: Support domain renewal when using mod_proxy within Location
</VirtualHost>

Include "/opt/bitnami/apache/conf/bitnami/bitnami-ssl.conf"

/opt/bitnami/apache/conf/bitnami/bitnami-ssl.conf

# Default SSL Virtual Host configuration.

<IfModule !ssl_module>
  LoadModule ssl_module modules/mod_ssl.so
</IfModule>

Listen 443
SSLProtocol all -SSLv2 -SSLv3
SSLHonorCipherOrder on
SSLCipherSuite "EECDH+ECDSA+AESGCM EECDH+aRSA+AESGCM EECDH+ECDSA+SHA384 EECDH+ECDSA+SHA256 EECDH+aRSA+SHA384 EECDH+aRSA+SHA256 EECDH !aNULL !eNULL !LOW !3DES !MD5 !EXP !PSK !SRP !DSS !EDH !RC4"
SSLPassPhraseDialog  builtin
SSLSessionCache "shmcb:/opt/bitnami/apache/logs/ssl_scache(512000)"
SSLSessionCacheTimeout  300

<VirtualHost _default_:443>
  RequestHeader set X-Forwarded-Proto "https"
  ServerName nodexplained.com
  #ServerAlias www.nodexplained.com
  DocumentRoot "/opt/bitnami/apache/htdocs"
  SSLEngine on
  SSLCertificateFile "/opt/bitnami/apache/conf/www.nodexplained.com.crt"
  SSLCertificateKeyFile "/opt/bitnami/apache/conf/www.nodexplained.com.key"

  # BEGIN: Configuration for letsencrypt
  Include "/opt/bitnami/apps/letsencrypt/conf/httpd-prefix.conf"
  # END: Configuration for letsencrypt
  # BEGIN: Support domain renewal when using mod_proxy without Location
  <IfModule mod_proxy.c>
    ProxyPass /.well-known !
  </IfModule>
  # END: Support domain renewal when using mod_proxy without Location
  # BEGIN: Enable non-www to www redirection
  RewriteEngine On
  RewriteCond %{HTTP_HOST} !^www\. [NC]
  RewriteCond %{HTTP_HOST} !^localhost
  RewriteCond %{HTTP_HOST} !^[0-9]+.[0-9]+.[0-9]+.[0-9]+(:[0-9]+)?$
  RewriteCond %{REQUEST_URI} !^/\.well-known
  RewriteRule ^(.*)$ https://www.%{HTTP_HOST}%{REQUEST_URI} [R=permanent,L]
  # END: Enable non-www to www redirection
  <Directory "/opt/bitnami/apache/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
  </Directory>
#  <Location/>
 #   SSLRequireSSL
  #</Location>

  ProxyPass / http://127.0.0.1:2368
  ProxyPassReverse / http://127.0.0.1:2368

  # Error Documents
  ErrorDocument 503 /503.html
  # BEGIN: Support domain renewal when using mod_proxy within Location
  <Location /.well-known>
    <IfModule mod_proxy.c>
      ProxyPass !
    </IfModule>
  </Location>
  # END: Support domain renewal when using mod_proxy within Location
</VirtualHost>

But the redirect still happens.

this is the one i have used to install ghost.

https://docs.bitnami.com/aws/apps/ghost/

I knew there was a reason I prefer Nginx. :slight_smile:

I’d say that your Apache config is broken. Non-www redirects to www, and https doesn’t work. Similarly, the pattern for portal, with a # doesn’t work. I think this is the cause of your problems.

Indeed, I don’t understand why you have all the rewrite rules. I’d have thought it’d be simpler, e.g.,


<VirtualHost *:80> 
  ServerName nodexplained.com
  ServerAlias www.nodexplained.com

  Redirect permanent / https://nodexplained.com/
</VirtualHost>

<VirtualHost *:443>
  ServerName nodexplained.com
  ServerAlias www.nodexplained.com

  <If "%{HTTP_HOST} == 'www.nodexplained.com'">
    Redirect permanent / https://nodexplained.com/
  </If>

  # Rest of config, including 
  # SSL and reverse proxy

</VirtualHost>

I don’t run Apache, and haven’t for some time, so you’ll need to check this thoroughly.