AMP pages won't load images

Issue Summary

  • Uploaded images are not loading/displaying on AMP pages. Only the featured image will load/display

Screenshot 2022-04-06 061455

Setup information

Ghost Version
4.34.1

Node.js Version
14.18.3

Operating system
Ubuntu 20.04

Database type
MariaDB

Are you using the default AMP template or a custom version?

Are you able to share a link to the page where it’s happening?

Tested it on the default and on a custom version of the amp.hbs both had the issue. (I also tested it on a local machine and production).

[Non AMP Version]Top 10 best mining pools for Ethereum (2022)
[AMP Version]Top 10 best mining pools for Ethereum (2022)

I also just installed the new Ghost and Nodejs version on production and local machine, the bug still persists.

Seems like it has something to do with the network or the SSL certificat, when I add an image with markdown to the site which is from another domain it works, but when I add an image url from my site, it won’t work.

Maybe @Kevin you know more about this since I saw you replied on a similar topic. Perhaps this network/SSL certificate issue would solve my scheduling problem as well Scheduling posts doesn't work

NVM seems like I found the problem and as always it was the DNS (my server uses a DNS server from the data center, which seems to be pointing my domain directly to 127.0.1.1 instead of through Cloudflare. Because of this, the server received a self-signed certificate from Cloudflare that the server is unaware of)

Nice. Glad you figured it out and posted your findings. They might be helpful to someone else with the same set up!