Blog Translation and Language Activation

Hello everyone,

I’m very new to Ghost but I’ve been a web publisher for 15 years. I’m migrating to GhostPro from a WordPress Managed installation and trying to set up the translation.

I’ve followed this tutorial step-by-step: https://ghost.org/tutorials/multi-language-content/

which allowed me to properly access my multi-language content.

Then I followed this tutorial to translate this theme (dawn, v. 1.5.0) which is multi-language ready: https://ghost.org/docs/api/v3/handlebars-themes/helpers/translate/

I’m setting up an English (en) and a Greek (el) version for my site. On the second tutorial it reads:


  1. Enable blog language

Verify that the .json translation file for your active theme is in place and then activate the language in the General settings of Ghost admin. Enter the correct language code into your settings menu and hit save.

I’m confused as there’s no “activation button” in GhostPro Settings. Where am I supposed to enter the code in the settings menu?!

Upon entering “en” in the Publication Language, the site properly loads the English version. When entering “el” in the same field, the Greek version loads correctly, both for my content and theme! I leave it to “en”, is that correct?

Then, when I access a post with “/el” in the URL, the post loads correctly in Greek, but the theme loads in English. Shouldn’t be the theme also be translated when adding “/el/” in the URL?

Thank you!