Cannot login to admin due to missing js / css files


#1

I am trying to access our admin dashboard after quite some time, but there seems to be missing .js and .css files all of a sudden

INFO [2019-01-23 08:35:29] “GET /assets/ghost.min-3a00413f28d137307afb86d64bddaa15.css/” 404 26ms
INFO [2019-01-23 08:35:29] “GET /assets/vendor.min-05e679b33815bd84607c2f4d14576051.js/” 404 30ms
INFO [2019-01-23 08:35:29] “GET /assets/ghost.min-5b8781318cc0347cc5179a324deb8532.js/” 404 36ms

The blog works fine:

But I cannot access the admin dashboard anymore:
https://blog.dathuis.nl/ghost

  • What version of Ghost are you using?
    I am actually not sure, I am running this in a docker container which uses the “:latest” from 7month ago.

  • What configuration?
    Just the default.

  • What errors or information do you see in the console?

INFO [2019-01-23 08:35:29] “GET /assets/ghost.min-3a00413f28d137307afb86d64bddaa15.css/” 404 26ms
INFO [2019-01-23 08:35:29] “GET /assets/vendor.min-05e679b33815bd84607c2f4d14576051.js/” 404 30ms
INFO [2019-01-23 08:35:29] “GET /assets/ghost.min-5b8781318cc0347cc5179a324deb8532.js/” 404 36ms


#2

I looked at it again, and it seems as if it somehow gets redirected to have a trailing /
The ghost version is 1.24

INFO [2019-01-29 10:51:28] "GET /assets/vendor.min-e71cb5c677f51d517625c8c87005a74a.css" 301 4ms
INFO [2019-01-29 10:51:28] "GET /assets/ghost.min-e2696e8973210c87cf935adb36cc5388.css" 301 2ms
INFO [2019-01-29 10:51:28] "GET /assets/vendor.min-abe84252a5128dded7c925fc6604948b.js" 301 3ms
INFO [2019-01-29 10:51:28] "GET /assets/ghost.min-6898dae0b1632b7fa1f7dcf1a7ff2543.js" 301 8ms
INFO [2019-01-29 10:51:28] "GET /assets/vendor.min-e71cb5c677f51d517625c8c87005a74a.css/" 404 73ms
INFO [2019-01-29 10:51:28] "GET /assets/ghost.min-e2696e8973210c87cf935adb36cc5388.css/" 404 82ms
INFO [2019-01-29 10:51:28] "GET /assets/vendor.min-abe84252a5128dded7c925fc6604948b.js/" 404 98ms
INFO [2019-01-29 10:51:28] "GET /assets/ghost.min-6898dae0b1632b7fa1f7dcf1a7ff2543.js/" 404 61ms

#3

The redirect is happening because the asset is not found (Ghost auto redirects all routes to trailing-slash).

You say you’re using Docker but haven’t told us anything about the specifics of your setup, that might be a good place to start for someone to be able to help you. Docker isn’t a supported platform so you may need to wait for someone in the community who knows it to give you some ideas of where to start digging into what’s gone wrong.


#4

Right, sorry for the lack of information.

I have investigated a bit further, and as I understand when using the admin panel, it should make the request to /ghost/assets/…

For me it does only /assets

The setup:
I am running ghost:latest ( was running 1.24 before, which had the same problem ) inside a docker container. There is a router in front of it which checks if the url starts with blog. and then forwards the complete request to ghost.

This setup worked perfectly fine for a couple of years but somehow now it has this issue on the admin page.

What baffles me is that the browser decides to request /assests/… and not /ghost/assests even though its a relative url.


#5

Ok, running it against blog.dathuis.nl/ghost/ with a trailing slash resolves this issue.


#6

:+1: it sounds like your local router was somehow not allowing Ghost to do it’s normal trailing slash redirect, typically any request to /ghost would return a 301 to /ghost/


#7

Yes, it is weird that this worked in the past though. Might be that the bookmark I normaly used already included a trailing slash or is this behaviour a recent addition?

Anyways, thank you for your help :slight_smile: and this can be closed.


closed #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.