Can't change the no-reply email for newsletters

Hey,

I’ve installed Ghost on digitalocean, and configured mailgun to send emails according to the guides.

It now sends newsletters from no-reply@mydomain.com, but when I try to change the from address in newsletter settings, it won’t save and just says “retry” in red.

I also changed the SMTP settings to add a from address, but it has no effect.

What am I doing wrong?

1 Like