'Command failed: /bin/sh -c sudo -S -p '#node-sudo-passwd#' systemctl is-enabled

I have several ghost instances running on a DO droplet. One of them is acting up.

Ghost-CLI version: 1.13.1
Ghost version: 3.3.0

On ghost start I get this

+ sudo systemctl is-enabled ghost_huldrahuseierforening
✖ Starting Ghost: huldrahuseierforening
An error occurred.
Message: 'Command failed: /bin/sh -c sudo -S -p '#node-sudo-passwd#'  systemctl is-enabled ghost_huldrahuseierforening


Debug Information:
    OS: Ubuntu, v16.04.6 LTS
    Node Version: v10.15.3
    Ghost Version: 3.3.0
    Ghost-CLI Version: 1.13.1
    Environment: production
    Command: 'ghost start

The instance starts, but it is annoying to get this error. I have re-installed the instance, but the error prevails, and only for that instance, and only for the start command.

The is-enabled output is different for this instance, returning linked instead of enabled

$ sudo systemctl is-enabled ghost_huldrahuseierforening
$ sudo systemctl is-enabled ghost_intergate

I suspect the issue is with the ghost user from ghost setup linux-user, and permissions.

Any help appreciated.


Ok, for the last re-install at least, think I found where the problem is. Somehow the instance name in .ghost-cli enden up being localhost.

  1. I edited it to being the url, with dashes instead of dots.
  2. I removed the old systemd .service file and ran ghost setup systemd

And the error resurfaced again. Some mismatch somewhere due to that.

Super anoying :pleading_face: