Installation Startup Problems


#1

Hi Everyone

I’m trying to setup Ghost on a Plesk 12 / Debian 8 box and I’m having the following issues.

I’ve followed all the instruction on the production install documentation along with creating the sudo user
and setting permissions of the “ghost” directory.

When I run ghost start as the sudo user I get the following error, Ghost doctor as the sudo user returns the same error

Running sudo command: systemctl is-active ghost_foxes-social
A ProcessError occurred.

Message: Command failed: /bin/sh -c sudo -S -p ‘#node-sudo-passwd#’ systemctl is-active ghost_foxes-social

unknown

Exit code: 3

Debug Information:
OS: Debian, v8.10
Node Version: v6.14.2
Ghost-CLI Version: 1.7.2
Environment: production
Command: ‘ghost start’

Additional log info available in: /home/foxesblog/.ghost/logs/ghost-cli-debug-2018-05-08T13_55_38_013Z.log

I would greatly appriciate any advice to get Ghost to start

Thanks All


#2

Hi @Aset :wave: Is there any other info in the log file? /home/foxesblog/.ghost/logs/ghost-cli-debug-2018-05-08T13_55_38_013Z.log

Plesk / Debian is outside of the supported stack so there’s not been any testing on it and there’s no explicit core support for that platform. Unless someone else has run into the same issue and is able to help you, your best bet will be to debug as much as possible yourself and provide any info that may be helpful for others to help you.


#3

Hi Kevin

Thank you so much, I finally fixed it by running ghost setup systemd which worked fine then ghost start launched it. : )

I have not setup the reverse proxy rule and am connecting to domain.com:2368 the port is active and loading before I create the proxy rule, but I get the error “Cannot Get /”

I feel I’m so close to getting this working now. could you pleas advise on the “Cannot get /” error. ty <3


#4

My first thought for that issue is your blog is configured under a subdirectory. Can you check your blog url (ghost config blog.url) and see if there’s a difference?


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.