Dawn - change works on local but not on hosted ghost instance


Forgive me if it’s a silly question, hoping someone can help?

I installed Ghost on an AWS EC2 ubuntu server and activated the Dawn theme. All working perfectly.

I wanted to reverse the order that the featured posts were displayed in to ‘oldest → newest’, so I made a small change on a local instance of ghost, ran yarn dev and I could see the change in my browser.


-- {{#get "posts" filter="featured:true" limit="all" as |featured|}}
++ {{#get "posts" filter="featured:true" limit="all" order="asc" as |featured|}}

I then ran yarn zip, which exports the zipped theme. I successfully upload and install through the Ghost admin panel but the change isn’t there when I load the site in my browser. I know hbs template changes are taking affect because I made some dummy changes in the same template file and they worked just fine.

Any idea why that specific change is working on local but not when uploaded to my server?

Thanks in advance!

Does order=“published_at asc” work? Just asc by itself doesn’t really make sense with the way that attribute works but I’m guessing there’s an SQLite (local) vs MySQL behaviour difference with how it’s handled which would explain why you’re seeing varying behaviour.

1 Like

That worked perfectly. Thanks Kevin!