Does ghost-mgr have a password?

#1

Hey all,

I’ve been running into an issue while trying to configure the apparent “one click install” on DigitalOcean. This is MacOS, using the Terminal. Everything seemed fine until the end, when trying to run service restart ghost has caught me in a death loop. Basically:

  1. only ghost-mgr has permission to run a restart
  2. ghost-mgr, which did not appear to have a password, suddenly has a password

I tried it with a blank field, with the root password, and with the password of the superuser I set up: no dice. I tried running the restart as root and as superuser. I have tried every Linux trick I can think of. Same error every time. At one point, I considered shouting SUDO at the screen because it seemed as likely to work as anything else. I did not set a password for ghost-mgr but it seems to have set itself one and refuses to tell me what it is.

Has anybody else into this problem? Is there a way around it? I have been staring at this error message all day and it has just totally confounded me.

#2

This is really weird, sorry this happened. I know that doesn’t help.

The one-click install is a collaboration between us & DO, but they ultimately hold the keys.

I recommend reaching out to their support, showing them this thread and telling them you’ve encountered a random/unknown failure case on the 1-click image and could they pull the logs to see what went wrong.

If you can, it would be helpful to create a second droplet and try again. This may also get you on your way whilst the issue is investigated.

2 Likes
#3

You can also try to get a standard Ubuntu droplet started and follow the installation procedures from here:

You can still run into issues (I did run into several recently) but in the end you can make it work. You can check out the forum for threads related to this.

#4

Thank you for the prompt response!

I’ve tried multiple droplets and run into the same issue. I feel like I should make clear that the blog runs fine—the issues are in trying to secure the droplet. It’s not a live site either: I’m spinning up/destroying a number of droplets just so I can get Ghost setup down properly. It’s not the end of the world, it was just a frustrating afternoon.

#5

You can check the steps here on how to secure the server (DO Linux droplets in general) as I don’t think you need to go into too much trouble messing with the Ghost user (but maybe that’s just my impression):

closed #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.