Email from adress

Dear Ghost community,

I am having trouble formatting my FROM email adress. In the config file I have:
“mail”: {
“from”: “‘Tischer.iosebastian@tischer.io”,
“transport”: “SMTP”,
“options”: {
“service”: “Mailgun”,
“host”: “smtp.eu.mailgun.org”,
“port”: 465,
“secureConnection”: true,
“auth”: {
“user”: “",
“pass”: "
*”
}

This is what email client show me:

Do you have any ideas?:slight_smile:

Thank you and warm regards.
Sebastian

Hi,
Use like below
"from": "Tischer.io<sebastian@tischer.io>",

Hi inoryum,
thank you for the reply, but it didn’t worked :frowning: it shows the same www.tischer.io as from name.

Hi,
You are welcome.
Did you checked your Blog title btw? The default from email is the blog title.

Hi inoryum,

thanks for your help again, I still have two problems:

1.) The from adress in my inbox show a skull icon and then www.tischer.io for transactional emails (signup etc.)

2.) I just noticed I can’t send marketing emails when a post is published, it says I need to check the mailgun configuration.

My config:
config.production.json:

  "mail": {
"transport": "SMTP",
"from": "'Sebastian Tischer' <sebastian@tischer.io>",
"options": {
  "service": "Mailgun",
  "host": "smtp.eu.mailgun.org",
  "port": 465,
  "secureConnection": true,
  "auth": {
    "user": "postmaster@mail.tischer.io",
    "pass": "*****"
  }
}

},

And in Ghost


I used the Mailgun private key.

I have no further idea what to do…

Thank you for your help :slight_smile:

Small update, I got it to work :slight_smile:

These are the crucial settings:

You need to enter the first part of the from email here, the rest (@www.tischer.io) is then added.
If you leave it blank, it will be noreply if you add for example mail then it will be mail@www.tischer.io

NOW the last problem to solve is:
How can I make the email to:
sebastian@tischer.io

I want the website to run under www.tischer.io but the mail should be normal sebastian@tischer.io.

It doesn’t seem to take the from settings out of the config.production.json:
“from”: “‘Sebastian Tischer’ sebastian@tischer.io”,

Does anybody have an idea? :slight_smile:

1 Like

Hi,
I will do some research & get back to u. As today I am off & it’s first Ramadan…

You are great, thanks a lot for your help - and take your time it is not ciritical :slight_smile:

One solution would be to use the core domain for your blog as well. I think that www.domain.com is not that important anymore. I personally prefer https://domain.com rather than https://www.domain.com (and you can always redirect www to core domain). If you do this, then your email config will show up normal:
image

Hi @Sebastian_Tischer.

I believe the transactional emails that Ghost sends (for example, the subscribe confirmation email) don’t use the from value in the config file.

from only seems to be used when sending out posts as newsletters.

Agreed with @dsecareanu

Thank you all for the replies, then I need to rethink my domain name :slight_smile:
Have a nice sunday everybody.

Warm regards
Sebastian

1 Like

so if you put this into your email from field:
Sebastian Tischer <sebastian@tischer.io>

the email address will get picked up from json, but the from name will be:
Sebastian Tischer @www.tischer.io

I’m using this as a partial solution at the moment…