Fail to start Ghost 4.22.2

I just install ghost on a fresh installed server.
Installation seems ok.
But it do not start ghost with the following error message

Message: Ghost was able to start, but errored during boot with: EACCES: permission denied, open '/var/www/docs.priv/versions/4.22.2/core/frontend/public/cards.min.css'

the file cards.min.css d not exist

> www-ghost@TNFTools:/var/www/docs.priv$ ls -ail /var/www/docs.priv/versions/4.22.2/core/frontend/public/
> total 68
> 1047355 drwxr-xr-x  2 www-ghost www-ghost  4096 Nov 12 18:33 .
> 1047331 drwxr-xr-x 10 www-ghost www-ghost  4096 Nov 12 18:33 ..
> 1047464 -rw-r--r--  1 www-ghost www-ghost 15406 Oct 26  1985 favicon.ico
> 1047444 -rw-r--r--  1 www-ghost www-ghost 19235 Oct 26  1985 ghost.css
> 1047453 -rw-r--r--  1 www-ghost www-ghost  8589 Oct 26  1985 ghost.min.css
> 1047606 -rw-r--r--  1 www-ghost www-ghost    98 Oct 26  1985 robots.txt
> 1047607 -rw-r--r--  1 www-ghost www-ghost  6522 Oct 26  1985 sitemap.xsl
> www-ghost@TNFTools:/var/www/docs.priv$

Any idea to fix this issue ?
Thanks in advance.

Please check if your www-ghost user have sudo permission?

Yes user www-ghost have sudo rights

www-ghost@TNFTools:/var/www/docs.priv$ sudo pwd
[sudo] password for www-ghost: 

Do you mean I have to start ghost with sudo rights ?
sudo ghost start

The file cards.min.css do not exist.
Start ghost should create it ?


No, you don’t need to start ghost with sudo but what I meant was if the user has sudo privileges. Seems it does…

Did you install ghost with ghost-cli or you are using one-click image from DO or similar?

If its a new instance I would suggest you uninstall ghost & then reinstall

to uninstall

ghost uninstall

Check if the same error Persits

if it is not a one-click image installation make sure you have followed the ghost official doc to install ghost

I confirm that I tried to uninstall and reinstall ghost with the official doc.
I have the same error message

Hi there! Can you, run ghost update --force to get 4.22.1 as per this GitHub issue to see if that fixes your problem?

1 Like

This fixed my problem fwiw

1 Like
ghost update --force

fixed problem for me too, moving to 4.22.1 version

Thanks you all