Failed at step CHDIR spawning /usr/bin/node: No such file or directory

Hello guys,
I tried to create a new instance of Ghost blog on my raspberry pi (raspbian) and I got some issues that apparently have something to do with node.

  • What’s your URL? This is the easiest way for others to debug your issue -
  • What version of Ghost are you using? 4.1.2
  • What configuration? production
  • What browser? -
  • What errors or information do you see in the console?
# I launched this :
ghost start

# Output from journalctl Changing to the requested working directory failed: No such file or directory Failed at step CHDIR spawning /usr/bin/node: No such file or directory Main process exited, code=exited, status=200/CHDIR Failed with result 'exit-code'.

# Note that when I executed the following
ll /usr/bin/node

# I got this
-rwxr-xr-x 1 root root 41230548 mars  30 12:16 /usr/bin/node
  • What steps could someone else take to reproduce the issue you’re having? Ghost install as usual.

For your information, I tested the same steps (basic creation of a Ghost instance using ghost install) on version 3.41.5 and it worked. However, it is not the case on version 4.1.2.

Would somebody have any idea on this issue ?
I am also interested to know whether other people got the same issue.

Thanks in advance and feel free to ask for more information.

Never mind, I just found the response.
The error is due to the wrong configured path in systemd file.
For example,
The ghost folder is located in /opt/app/ghost1
The ghost systemd configuration contains WorkingDirectory=/another/folder instead of WorkingDirectory=/opt/app/ghost1.